Closed Bug 554905 Opened 12 years ago Closed 12 years ago

Asp.net Ajax Telerik Radwindow not working

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
major

Tracking

()

VERIFIED WORKSFORME
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: christoph.jarisch, Assigned: brendan)

References

()

Details

(Keywords: regression)

User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; GTB6.4; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.2)
Build Identifier: MozillaDeveloperPreview/3.7a3

Telerik 2008.3 Asp.net ajax - javascript "window.radopen" does not work (in all prev. versions of firefox it worked!) -> Error: Sys.invalidoperationexception "Der Vorgang ist aufgrund des aktuellen Zustands des Objekts ungültig"

Reproducible: Always

Actual Results:  
Ajax Request wich does nothing...

Expected Results:  
Open a Telerik Radwindow
Thanks for your report and sorry for the late reply. Unfortunately there's not enough information here to lead to a code fix. At the very least we'd need a link to the problematic page.

I would recommend to report the problem to the ajax toolkit vendor, since they should also be interested in having their widgets work with the upcoming Firefox version.

To figure out what caused the change in Firefox behavior and whether it was an intended change or a regression it's useful to figure out a "regression window" - http://new.quality.mozilla.org/documents-home/bugs-docs/bug-triaging-guidelines/finding-regression-windows
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → INCOMPLETE
Please go to http://intern.inforaum.com/login.aspx !
There click on "Forgotten password?"!
There should be opened a window (iframe)! So it does in IE, Safari, Chrome and Opera! The actual Firefox version (3.6.8) also does it!

It seems that you don't allow to give this object an id (js)! Why not?
Thanks for the link (I can reproduce the problem on the current trunk build, works in Firefox 3.6.8 on Mac). Someone will still have to figure out when exactly this regressed and/or try to create a smaller testcase.
Status: RESOLVED → UNCONFIRMED
OS: Windows 7 → All
Product: Firefox → Core
QA Contact: general → general
Resolution: INCOMPLETE → ---
Version: unspecified → Trunk
I can also reproduce it with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b6pre) Gecko/20100902 Firefox/4.0b6pre

Not really sure how widespread this toolkit is under use but it's definitely a regression which could affect a lot of people.

Christoph, could you test some older beta releases of Firefox 4.0 and check when the problem has been started? Narrowing down the regression range is necessary for us to find the causing patch. Thanks.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: x86 → All
A quick check showed me that's an already older regression. Even alpha 1 (20100208) doesn't handle it correctly anymore.
Looking out for the window. Results should be available soon. Regressed sometime between 09090103 and 09100103.
blocking2.0: --- → ?
bisect says:

The first bad revision is:
changeset:   32658:842e6c09e35a
user:        Brendan Eich <brendan@mozilla.org>
date:        Thu Sep 03 14:41:19 2009 -0700
summary:     Join lambdas assigned or initialized as methods to the compiler-created function object if we can, with a read barrier to clone on method value extractions other than call expressions (471214, r=jorendorff).
Assignee: nobody → general
Blocks: 471214
Component: General → JavaScript Engine
QA Contact: general → general
Does this reproduce in the latest tm hourly? Earlier today I pushed a fix for bug 592412.

/be
Assignee: general → brendan
I have no idea about hourly, but I did try that patch locally and it doesn't seem to help.  Assuming I rebuilt all the stuff I needed to correctly, that is...
blocking2.0: ? → betaN+
WFM today.
Status: NEW → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → WORKSFORME
Verified with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101201 Firefox/4.0b8pre ID:20101201030318
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.