CSS: 1pt border is wider on the right and on the bottom

VERIFIED DUPLICATE of bug 63336

Status

()

defect
P3
minor
VERIFIED DUPLICATE of bug 63336
19 years ago
18 years ago

People

(Reporter: burnus, Assigned: dcone)

Tracking

({css1, polish, testcase})

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(2 attachments)

Reporter

Description

19 years ago
This is with 2000-19-04-21/Linux

Goto the URL. There should be an <div> which uses this CSS:
  border: 1pt solid black;
Let's assume the top and left border are 1pt wide.Well, the right border seems
to be 3pt and the bottom 2pt wide.

Expected result: all sides should have the same width.

Comment 1

19 years ago
I confirm the bug on the Mac. To reproduce, resize the window very slowly to 
change its width (on the Mac: Cmd-Resize)
==> Every 5 pixels, the border on the right is 2 pixels wide instead of 1 pixel.
==> The border at the bottom is always 2 pixels wide instead of 1 pixel.

The bug doesn't happen if the border width is specified as '1px' or 'thin' 
instead of '1pt'.

I think I saw something like that several months ago already: a border width that 
changes on resize... Could it be a problem of conversion between points and 
pixels?

Reassigned to kmcclusk and CCd dcone, like other bugs with borders.
Assignee: pierre → kmcclusk
Status: UNCONFIRMED → NEW
Component: Style System → Layout
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
Triaging CSS bugs...

Tobias: nice catch. Thanks!
Target Milestone: --- → Future
reassigning to don.
Assignee: kmcclusk → dcone
Assignee

Comment 6

19 years ago
This is due to the fact that all the border boundaries and placements are in 
twips.. this causes a nightmare of roundoff errors when these values are 
converted to pixels.  These need to be pre-calculated on pixel boundaries.. so 
the final results are on pixel boundaries.  
Status: NEW → ASSIGNED
Assignee

Comment 7

19 years ago

*** This bug has been marked as a duplicate of 63336 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
Netscape's standard compliance QA team reorganised itself once again, so taking 
remaining non-tables style bugs. Sorry about the spam. I tried to get this done 
directly at the database level, but apparently that is "not easy because of the 
shadow db", "plus it screws up the audit trail", so no can do...
QA Contact: chrisd → ian
vrfy dupl
Status: RESOLVED → VERIFIED

Updated

17 years ago
No longer blocks: 134942
You need to log in before you can comment on or make changes to this bug.