Open in New Tab Context Menu pops up for javascript:void(0) links

VERIFIED FIXED

Status

Firefox for Android Graveyard
General
VERIFIED FIXED
8 years ago
4 years ago

People

(Reporter: aakashd, Assigned: mfinkle)

Tracking

Fennec 1.1
Bug Flags:
in-litmus +

Details

(Reporter)

Description

8 years ago
Build Id:
Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2.2pre) Gecko/20100325 Namoroka/3.6.2pre Fennec/1.1a2pre

and

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.3a3pre) Gecko/20100325 Namoroka/3.7a3pre Fennec/1.1a2pre

Steps to Reproduce:
1. Go to www.google.com/news
2. Scroll down to a "Email this story" link in one of the top stories
3. long tap on "Email this story" to open the context menu

Actual Results:
The context menu opens with the "open in new tab" option

Expected Results:
The context menu on firefox blocks "open in new tab" for javascript urls. I'd expect mobile firefox to do the same since all this does is open about:blank
fix added to patch in bug 554951
Assignee: nobody → mark.finkle
Depends on: 554951
(Assignee)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Updated

8 years ago
Flags: in-litmus?
(Reporter)

Comment 2

8 years ago
verified FIXED On builds:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2.3pre) Gecko/20100329 Namoroka/3.6.3pre Fennec/1.1a2pre

and

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.3a4pre) Gecko/20100329 Namoroka/3.7a4pre Fennec/1.1a2pre
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

8 years ago
litmus testcase https://litmus.mozilla.org/show_test.cgi?id=11653 created to regression test this bug
Flags: in-litmus? → in-litmus+
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.