Firefox omitting file extension when downloading files from certain sites

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: fehe, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a4pre) Gecko/20100324 Firefox/3.5.8 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a4pre) Gecko/20100324 Minefield/3.7a4pre ID:20100324030852

Ever since the check-in for bug 514494, Firefox will omit the file extension when downloading files from some sites.

For instance, files downloaded from the following sites have extension omitted:
1. http://sourceforge.net/projects/flafi/files/
2. http://hourly-archive.localgho.st/hourly-archive2/mozilla-central-win32/


Reproducible: Always

Steps to Reproduce:
1. Visit any of the links provided herein
2. Click to download any of the files
3. File is downloaded, but extension is dropped.
(Reporter)

Updated

9 years ago
Blocks: 514494
Keywords: regression
Version: unspecified → Trunk
(Reporter)

Comment 1

9 years ago
Created attachment 435090 [details]
Screenshot showing filename truncation in Save dialog

Additionally, this bug causes some filenames, displayed in the "File name:" field of the save dialog, to be truncated such that the first set of alphanumeric characters, after the first dot encountered, is treated as though it was the extension, and everything else thereafter is truncated.

"VirtualBox-3.1.6-59338-Win" becomes "VirtualBox-3.1"

See attached screenshot
I can't reproduce this at all on Windows 7 -- inspecting with a debugger, everything seems to be working properly. Do you have it set up so that each time a file is downloaded it asks you to save it?
OK, seems like something that only happens on XP. Looking.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I've backed out the operative part of bug 514494.
So I've investigated a little more and this only shows up if file extensions are hidden, which is why I missed it. :(
(Reporter)

Comment 6

9 years ago
I'm still getting truncation of the extension.  Not as pervasive as before, but it's still happening.  For example:

1. Visit https://addons.mozilla.org/en-US/firefox/addons/versions/59
2. Right-click the first "Add to Firefox" button and choose "Save Link As..."
3. Save the file.
4. Note that the file is saved without extension.
(Reporter)

Comment 7

8 years ago
WFM with latest nightlies

Mozilla/5.0 (Windows NT 5.1; rv:2.0b7pre) Gecko/20100930 Firefox/4.0b7pre ID:20100930041305

http://hg.mozilla.org/mozilla-central/rev/5a2012482a63
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.