Closed Bug 555149 Opened 12 years ago Closed 12 years ago

JM: (64-bit) "Assertion failed: LIR type error (start of writer pipeline): arg 1 of 'ldq' is 'int' which has type int32 (expected int64): 0 (../nanojit/LIR.cpp"

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: gkw, Unassigned)

References

Details

(Keywords: assertion, regression, testcase)

Attachments

(1 file)

(function() {
  eval("\
    (function() {\
      for each(let w in[new Number,[''],new Number,new Number(.5)]) {\
        print(w|\"\");\
        print()\
      }\
    }\
  )")()
})()


asserts 64-bit js debug shell on JM tip with -m and -j at Assertion failed: LIR type error (start of writer pipeline): arg 1 of 'ldq' is 'int' which has type int32 (expected int64): 0 (../nanojit/LIR.cpp:2610)

This occurs both on Mac and Linux, if I'm not wrong.
I'm quite sure this doesn't occur on TM tip:

$ ./js-dbg-64-tm-darwin -j w6636-reduced.js 
0

0

0

0

$ ./js-dbg-64-jm-darwin -m -j w6636-reduced.js 
0

0

0

0
Assertion failed: LIR type error (start of writer pipeline): arg 1 of 'ldq' is 'int' which has type int32 (expected int64): 0 (../nanojit/LIR.cpp:2610)
Abort trap
Summary: JM: "Assertion failed: LIR type error (start of writer pipeline): arg 1 of 'ldq' is 'int' which has type int32 (expected int64): 0 (../nanojit/LIR.cpp" → JM: (64-bit) "Assertion failed: LIR type error (start of writer pipeline): arg 1 of 'ldq' is 'int' which has type int32 (expected int64): 0 (../nanojit/LIR.cpp"
Hrm, I can't reproduce this. Could you show me the full backtrace? Usually that's enough to fix a LIR type error.
Backtraces, normal and full.
I can still reproduce this with the following changeset, on 64-bit Mac debug shell:

http://hg.mozilla.org/users/danderson_mozilla.com/jaegermonkey/rev/0075ab7ae8fe
This revision seemingly fixed this issue:

The first good revision is:
changeset:   41033:a8780485cc7b
user:        David Anderson
date:        Wed Apr 14 13:51:45 2010 -0700
summary:     [JAEGER] Added JMFLAG for disabling trace hints.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
(In reply to comment #5)
> This revision seemingly fixed this issue:

Or that might have been the wrong revision. Whatever the case, it's now WFM.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.