mozilla-bin dumped core file

VERIFIED WORKSFORME

Status

SeaMonkey
Build Config
P3
blocker
VERIFIED WORKSFORME
17 years ago
13 years ago

People

(Reporter: tracy, Assigned: Daniel (Leaf) Nunes)

Tracking

({smoketest})

Trunk
x86
Linux
smoketest

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
linux commercial build 2000-10-06-08-M18

after installation but before the application starts up.  the terminal window 
displays

Oh no!  ./mozilla-bin just a dumped core file. 
then it asks if I'd like to debug.

seen with installer bits and tar ball bits.
(Reporter)

Updated

17 years ago
Keywords: smoketest
Summary: mozilla-bin dumped core file → mozilla-bin dumped core file

Comment 1

17 years ago
--> build config, cc leaf
Assignee: asa → cls
Component: Browser-General → Build Config
QA Contact: doronr → granrose

Comment 2

17 years ago
confirmed with trunk mozilla bits as well

Comment 3

17 years ago
It's in libprefs somewhere:

#1  0x4082d3a0 in NSGetModule ()
   from /u/akkana/seamonkey/mozilla-trunk/components/libpref.so
#2  0x408aa98e in NSGetModule ()
   from /u/akkana/seamonkey/mozilla-trunk/components/libcaps.so

(big help, huh?  But that's all I can get from a release build; hopefully
someone with a current debug trunk build can get us more.)
(Reporter)

Comment 4

17 years ago
seeing again on linux commercial and mozilla bits 2000-10-06-12-M18

note: linux commercial branch build 2000-10-06-10-MN6 was okay.

Comment 5

17 years ago
*** Bug 55551 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

17 years ago
i am hoping this is a build problem (tinderbox builds are running, as are
developer optimized builds).

doing clobber to be sure.
Assignee: cls → leaf

Comment 7

17 years ago
*** Bug 55551 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
I'm seeing this with 2000100612 but not with anything prior (currently using
2000100610).

Comment 9

17 years ago
mozilla trunk build 100613 is workign.  Resolving fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 10

17 years ago
I see this in commercial also:

#0  0x40f28872 in nsPref::PrefIsLocked (this=0x812e3e8, 
    pref=0x401a4c90 "À­\023", res=0x4) at nsPref.cpp:1164
#1  0x412e5bc9 in nsCPrefsManager::SetBoolPref (this=0x83049d8, 
    pref=0x85ffe00 "aim.session.firsttime", val=0, buddyName=0x0, global=1)
    at /builds/branch/ns/AIMGlue/src/nsCPrefsManager.cpp:249
#2  0x40146f75 in XPTC_InvokeByIndex (that=0x83049d8, methodIndex=10, 
    paramCount=4, params=0xbfffdc8c) at xptcinvoke_unixish_x86.cpp:134
#3  0x40f8addd in ?? ()
   from /builds/branch/ns/dist/bin/components/libxpconnect.so
#4  0x40f8cf37 in ?? ()
   from /builds/branch/ns/dist/bin/components/libxpconnect.so
#5  0x401edc24 in js_Invoke (cx=0x84d5148, argc=4, flags=0) at jsinterp.c:820
#6  0x402019f7 in js_Interpret (cx=0x84d5148, result=0xbfffe7d8)
    at jsinterp.c:2621
#7  0x401edc9d in js_Invoke (cx=0x84d5148, argc=1, flags=2) at jsinterp.c:837
#8  0x401edffc in js_InternalInvoke (cx=0x84d5148, obj=0x84d0d48, 
    fval=139272584, flags=0, argc=1, argv=0xbfffea8c, rval=0xbfffe95c)
    at jsinterp.c:909
#9  0x401bf8f7 in JS_CallFunctionValue (cx=0x84d5148, obj=0x84d0d48, 
    fval=139272584, argc=1, argv=0xbfffea8c, rval=0xbfffe95c) at jsapi.c:3193
#10 0x4053925d in ?? () from /builds/branch/ns/dist/bin/./libjsdom.so
#11 0x4058d97c in ?? () from /builds/branch/ns/dist/bin/./libjsdom.so
#12 0x416ba03c in ?? ()
   from /builds/branch/ns/dist/bin/components/libgklayout.so
#13 0x416bbc45 in ?? ()
   from /builds/branch/ns/dist/bin/components/libgklayout.so
#14 0x4054e0b9 in ?? () from /builds/branch/ns/dist/bin/./libjsdom.so
#15 0x419dcb16 in ?? ()
   from /builds/branch/ns/dist/bin/components/libgklayout.so
#16 0x410ebf71 in ?? ()
   from /builds/branch/ns/dist/bin/components/libdocshell.so
#17 0x40bd7fac in ?? ()
   from /builds/branch/ns/dist/bin/components/liburiloader.so
#18 0x40bd799f in ?? ()
   from /builds/branch/ns/dist/bin/components/liburiloader.so
#19 0x40bd77f7 in ?? ()
   from /builds/branch/ns/dist/bin/components/liburiloader.so
#20 0x409ae742 in ?? () from /builds/branch/ns/dist/bin/components/libnecko.so
#21 0x40a11af3 in ?? () from /builds/branch/ns/dist/bin/components/libnecko.so
#22 0x40995d39 in ?? () from /builds/branch/ns/dist/bin/components/libnecko.so
#23 0x409952e7 in ?? () from /builds/branch/ns/dist/bin/components/libnecko.so
#24 0x4012823e in PL_HandleEvent (self=0x85a3998) at plevent.c:580
#25 0x4012805c in PL_ProcessPendingEvents (self=0x80ae9a0) at plevent.c:513
#26 0x40129ea9 in nsEventQueueImpl::ProcessPendingEvents (this=0x80ae978)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 11

17 years ago
cvs pull wasn't working from friday (as per stack trace) but nightly linux build
2000100809 MN6 on linux starts up fine.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 12

17 years ago
marking verified on linux build 2000-10-09-06-M18
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.