Video player used on comcast.net does not work when Adblock + is enabled.

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: Bill Hatfield, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2 (.NET CLR 3.5.30729)

This is a recent development that I believe may have coincided with a recent Firefox auto update (within last 3 days), though I'm not positive. I think I recollect an Adobe Flash update also around the same time. My Flash is currently at 10.0.45.2. Yourtube video player works fine. After I click a video my status bar seems to be normal, showing that data is being transferred, but it never completes and no video plays. A normal indicator that a video is loading is an animated arrow in the middle of the video screen. That does not occur when Adblock + is enabled. As soon as I disable Adblock + 1.1.3 and restart Firefox, videos work fine. I have enabled and disabled adblock + several times and there is no mistaking the symptom I described.

Reproducible: Always

Steps to Reproduce:
1.I already have adblock + installed and enabled.
2.Then Go to http://www.comcast.net/video/is-sandra-bullock-back-home-/1451136596/Comcast/1450740980/ This goes directly to a video on comcast.net Fancast.
3.If this video is not available, click on one of the others displayed vertically on the left.
3.
Actual Results:  
No video plays and there is no animated - circling arrow in the middle of the screen which is the normal indicator a video is loading. My web status bar says data is transferring.

Expected Results:  
Video loads and starts within a couple seconds.

The comcast video player usually plays an advertisement first. I did not see any other areas of the screen where an ad appeared when Adblock + was enabled. The video player may be the only ad window on the page. While playing an ad, It even says on top edge of the player frame: Advertisement - Your video will resume in xx seconds.

I never attempted to add the comcast fancast video player to the adblock + block list. I could try to remove it if I new what I was looking for.
(Reporter)

Comment 1

8 years ago
Poor writing. After the sentence "Yourtube video player works fine." all the following text is describing the problem I see when using comcast player.

I am running windows xp - up to date. My ATI vid card (GeForce 9600 AGP) is running dated drivers, but current ATI drivers don't run properly in some software I use. So, I had to return to previous version.
And why should this be a Firefox bug if it works without adblock plus ?
The usual story is that adblock plus blocks the video because of some filter rules.
(Reporter)

Comment 3

8 years ago
I never said it was a Firefox problem, I was on Adblock web site for the purpose of posting there. Some click ended me on bugzilla. I didn't know Adblock was not getting it. My intention was always for Adblock to handle it.
The issue is worse in most cases.
The issue is not in Adblock itself, it's in one of the used filter lists which are not maintained by the adblock plus developer.
Do you have one filter list or more in use ?
(Reporter)

Comment 5

8 years ago
One. EasyList USA
(Reporter)

Comment 6

8 years ago
One. EasyList USA
(Reporter)

Comment 7

8 years ago
Looking in the Adblock+ preferences the following are included under the heading "My ad blocking rules". At the end of each is a check box labeled "Enabled". All have a check it them. After this there is one more "Enable" box. It is for EasyList USA. It is also checked.

I tried unchecking the box next to www.comcast.net..., applied and restarted firefox but it made no difference. I rechecked the box.

|http://www.capcom.com/us/*
|http://static.capcom.com/unity/*
|http://feed.untd.com/feed/*
|http://webmaila.uolimg.com/i2/*
http://www.comcast.net/ui/swf/videochannel/VideoChannelPlayer.swf?32552
(Reporter)

Comment 8

8 years ago
I fixed the problem in my machine by disabling the following individual filter from EasyList (USA).

About 3/5 the way down the list, find the sub-list labeled "Third-party ads" (spelled exactly that way). Go down about a little more than a page worth where you will find the following.

NOTE: The first 2 characters are vertical lines (I do not know how type these lines) followed immediately by:
      lightningcast^*/getplaylist?$object_subrequest,third-party

Then;
- Uncheck the box
- click apply.
- You don't have to restart Firefox but you do need to click a video.

I have enabled and disabled this script several times to verify. I have not rechecked all the other boxes to see if more than 1 needs to be unchecked. That's for another day, because there are thousands. I tried to uninstall and reinstall EasyList but the unchecked boxes remain. I also tried to uninstall and reinstall Adblock+ but they still remain unchecked.

Thank you for your responses and direction in resolving this,
Bill
marking invalid (not a Firefox bug).
great that you have found the reason
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.