Page is repainted to default zoom level after open a link in new tab/middle-click.

RESOLVED FIXED in Firefox 3.7a4

Status

()

RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: alice0775, Assigned: rflint)

Tracking

({regression})

Trunk
Firefox 3.7a4
x86
All
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US;
                  rv:1.9.3a4pre) Gecko/20100326 Minefield/3.7a4pre ID:20100326040105
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US;
                  rv:1.9.3a4pre) Gecko/20100326 Minefield/3.7a4pre ID:20100326040105

Page is repainted to default level after open a link in new tab.

Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Open any page
3. Zoom in (Ctrl + Ctrl + Ctrl + Ctrl + )
4. Open a link in new background tab (Middle click a link)

Actual Results:
 Page is repainted to default zoom level.

Expected Results:
 Page should not be repainted.
 and should  keep zoom level.
(Reporter)

Updated

9 years ago
Keywords: regression
(Reporter)

Comment 1

9 years ago
the following seems to fix the issue .
In FullZoom.onLocationChange in browser.js

    // Avoid the cps roundtrip and apply the default/global pref.
    if (aURI.spec == "about:blank") {
-      this._applyPrefToSetting();
+      this._applyPrefToSetting(undefined , aBrowser);
      return;
    }
(Reporter)

Updated

9 years ago
Blocks: 555211

Updated

9 years ago
OS: Windows 7 → All
Summary: Page is repainted to default level after open a link in new tab. → Page is repainted to default zoom level after open a link in new tab.

Comment 2

9 years ago
Can confirm that this is always reproducible. Using win7 64it, build details below:

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a4pre) Gecko/20100326 Minefield/3.7a4pre ID:20100326040105
Created attachment 435357 [details] [diff] [review]
Patch

Doh. onLocationChange gives us the background browser for this case while calling _applyPrefToSetting with both parameters undefined acts on the foreground browser...
Assignee: nobody → rflint
Status: NEW → ASSIGNED
Attachment #435357 - Flags: review?(myk)
Duplicate of this bug: 555965

Updated

9 years ago
Summary: Page is repainted to default zoom level after open a link in new tab. → Page is repainted to default zoom level after open a link in new tab/middle-click.
Pushed with r=dtownsend over IRC.
http://hg.mozilla.org/mozilla-central/rev/cf17c30f39b7
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a4

Updated

9 years ago
Duplicate of this bug: 556227
Comment on attachment 435357 [details] [diff] [review]
Patch

As it's already been reviewed, it no longer needs my review, so cancelling the request.

Sorry I didn't get to this before you found review elsewhere! :-/
Attachment #435357 - Flags: review?(myk)
You need to log in before you can comment on or make changes to this bug.