TB hangs on process print job -before print dialog window pops up

RESOLVED WORKSFORME

Status

Thunderbird
General
--
minor
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Robert Ricks, Unassigned)

Tracking

({hang})

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2 (.NET CLR 3.5.30729)
Build Identifier: V3.03

When going into a email, if you open a pdf attachment then go back to thunderbird without exiting acrobat and try to print the email - the print processing window will pop up and hang (only if that folder is not synchronized).  You will have to kill the tb process, even if you exit all running program.   There are two workarounds for this:

   1. close attachment before trying to print email
   2. make the folder synchronized 



Reproducible: Always

Steps to Reproduce:
1.open email with pdf attachment
2 [review].open pdf with acrobat
3.go back to tb withour closing acobat
4.try to print
Actual Results:  
TB hangs.  Your able to close TB, but will need to kill process also for tb to run normally after hanging.
(Reporter)

Updated

8 years ago
Summary: TB hangs on process print job -before print dialog windows pops up → TB hangs on process print job -before print dialog window pops up
(Reporter)

Updated

8 years ago
Keywords: crash
Version: unspecified → 3.0
(Reporter)

Comment 1

8 years ago
none

Comment 2

8 years ago
> When going into a email, if you open a pdf attachment then go back to
> thunderbird without exiting acrobat and try to print the email - the print
> processing window will pop up and hang (only if that folder is not
> synchronized). 

This is bug 529210, and I can reproduce your steps up to that point. While the "Cancel" button in the preparing-to-print dialog is disabled, closing it with the [x] in the upper right corner works for me (Thunderbird 3.0.4, WinXP).

> You will have to kill the tb process, even if you exit all
> running program.

I'm unable to reproduce this part though. Can you go into the Config Editor and set mail.server.default.mime_parts_on_demand to "false"? If the problem is resolved then, it should be a duplicate of that other bug.
Keywords: crash → hang
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 3

8 years ago
Robert, you've marked this "fixed" - can you be specific what resolved the issue for you so that this bug can be closed properly? Thanks.
Resolution: FIXED → INCOMPLETE
(Reporter)

Comment 4

8 years ago
upgrading to version TB 3.0.4 fixed problem.
Resolution: INCOMPLETE → FIXED

Comment 5

8 years ago
Ok, so that would be "works for me" then (a resolution of "fixed" can only be used if a bug was identified in this report and actual code changes made).

-> WFM
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.