Please provide user setting for disabling BACKSPACE navigation behaviour

RESOLVED WORKSFORME

Status

()

--
enhancement
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: u84638, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2 (.NET CLR 3.5.30729)

There are many discussion in bugs from back to 2001 to today on the BACKSPACE behaviour. There seem to be people that like the current behavior as a shortcut for page back. This also seems to be the accepted behavoiur among browser implementors, I found Opera, Chrome and IE behaving the same way.

OTOH, all "average users" I know do not use Keyboard navigation, but expect the browser to act as they know it from word processors, mainly if they are inside a form, be it a web mail application or community thing or whatever. Those kinds of applications have gained an increasing importance since the disucssions on BACKSPACE began. I myself just lost an hour of work because of this behavior, my wife complains at least once a week about lost e-mails because she hit backspace and had not noticed the text field had lost focus. This IS a serious problem and a permanent source of annoyance about their browsers for many users.

It could easily (well, from a user's POV; I don't know about the implementation) be solved with a checkbox in the general settings, saying: "Do not go to the previous page when hitting BACKSPACE".

Reproducible: Always

Steps to Reproduce:
1. Open a Yahoo mail account and klick the "New message" button
2. Type something into the message field
3. Click anywhere outside the message field and hit Backspace
Actual Results:  
You are redirected to the previous page; if you hit the Forward button, the text is lost.

Expected Results:  
I would expect nothing to happen, if the focus is not in a text field, textarea or other editable area.

Please do not look at this submission as a reopening of the discussion on the correct behavior of BACKSPACE. This is a real and serious problem for a significant number of users, please give us a choice to adjust this key to act as we expect it.

Comment 1

9 years ago
See <http://kb.mozillazine.org/browser.backspace_action> - you can change the value of browser.backspace_action (which has a different default on Windows than on Linux.

You could have found this on the SUPPORT site (<http://support.mozilla.com/>), no need to file a bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

9 years ago
Thank you for your comment. I had indeed found this article before. As soon as you open about:config, Firefox states that changes might affect the stability or security of Firefox, and you have to confirm you know what you are doing. So I did not dare to do changes there.

About:config is great for changes to be made by users with a high IT competence. It is not suitable for the majority of users. That is why I reconfirm my request to introduce the browser.backspace_action setting into the settings dialog. 

(I would even suggest to make 2 the default value, as rather highly skilled or specially interested users use keyboard navigation - they are more likely to set their preferred settings than the majority of the users.)

I do not feel I am entitled to re-set the status of this bug to "unconfirmed", but I would highly appreciate this to be reconsidered.

Comment 3

9 years ago
The original Mozilla (similar to Netscape Navigator) was a product with a very large amount of preferences, many of which could be controlled in dialog boxes. But regular users complained that it was sometimes very difficult to chnage settings, and it also made the browser very large and slow.

Firefox was designed from the ground up to be much simpler, and removed many options. That is one of the reasons that Firefox became so popular. At the same time the about:config screen was introduced for people that wanted more control (in general, this means the developers and testers itself), without resorting to editing the preference files directly and restarting the browser everytime. Some of the options can indeed mess up things, and are sometimes a reason why some people have problems (like when they forget how to undo the change). Giving people easier access to the options will *not* be helping at all. And if it was me, I think we should remove most of the options anyway (I prefer a product with as less options as possible), so it's still to easy to change them, and get into trouble.

I think that this option will never be present in a dialog box, there are many more options that could be useful for some people, and there will always be a debate which option to include and which not. If you look in the bugzilla database, then you see that not many people asked for this feature to be changed (because they're used to this behavior in Inter Explorer). On the contrary, you will find many request for the behavior in Linux to be changed : they want to *add* the backspace button !

If you really want to change a setting, then you should think of better options, like bug 57805. That wants to add a frontend to change ALL keyboard shortcuts. That would be much more useful than arguing button per button. browser.backspace_action is not really build for changing it for a single user, but for setting the default for an entire platform.
(Reporter)

Comment 4

9 years ago
Thank you for your patient and detailled answer. Indeed, bug 57805 addresses my topic more generally, so I agree with the Resolved status and apologize for having filed an unnecessary bug. I hope, after 10 years, bug 57805 will get resolved soon!

Anyway: there is an Add-on called DisableBackspaceNavigation that does disable the navigation function of BACKSPACE. It has been downloaded almost 27000 times so far.
You need to log in before you can comment on or make changes to this bug.