Error dialog popups when checking mail after resuming from standby - "The server XXX rejected the connection"

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Backend
RESOLVED WORKSFORME
8 years ago
6 years ago

People

(Reporter: Miguel Julier, Unassigned)

Tracking

SeaMonkey 2.3 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Halloween2011Bug])

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.9.1.8) Gecko/20100205 SeaMonkey/2.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.9.1.8) Gecko/20100205 SeaMonkey/2.0.3

When I resume the computer from standby, wait for the network link to be established again, and then ask Seamonkey to get new mail from my POP3 accounts, I get several error popups (one for each account) saying "Alarm - The server XXX rejected the connection" (I translate from French).

This does not happen with Thunderbird 2.0.0.24, but it happens with Seamonkey 2.0.3 and previous versions.

Reproducible: Always

Steps to Reproduce:
1. In Seamonkey, configure a POP3 account with "check mail every 10 minutes"
2. Put computer in standby for more than 10 minutes
3. Wake-up the computer
4. Wait for the network link to be established again (on Linux Ubuntu, I have a notification saying "network link established"
5. Ask Seamonkey to retrieve new messages for all accounts 
Actual Results:  
Several pop-up windows at the center of the screen (one for each account) saying "The server XXX rejected the connection"

Expected Results:  
Ideally: as soon as the network link is established, retry the automatic retrieving of new mail.

Next best solution: after the first attempt has failed (because the computer is over-due to check the mail but it tried to do so before the network was established), which is already does silently, whenever the user asks to retrieve the messages the software should do so and display an error pop-up only if this new attempt also fails. It should not display an error that has been remembered because the automatic attempts produce no error pop-ups.

Comment 1

8 years ago
do you see this also with thunderbird 3?
Summary: Error popups when checking mail after resuming from standby → Error dialog popups when checking mail after resuming from standby - "The server XXX rejected the connection"

Comment 2

8 years ago
A log of your mail session when this error occurs might help. Here is how to turn on logging.

https://wiki.mozilla.org/MailNews:Logging#Linux.2Funix
http://email.about.com/od/mozillathunderbirdtips/qt/et_mail_log.htm

Once you get a log of the session where you get the errors, please attach that log as an attachment in this bug.
(Reporter)

Comment 3

8 years ago
Yes, the same bug appeared in Thunderbird 3.0.4 for Linux.

I do not understand the log file for POP3, but this is what I did:
  1) configure one POP3 mailbox with "leave mail on server", "check at startup", "check every 1 minute"
  2) start Thunderbird with:
export NSPR_LOG_MODULES=POP3:4;export NSPR_LOG_FILE=/tmp/tbird.log.txt; thunderbird3 &
  3) let Thunderbird check the mail (automatically)
  4) put computer in stand-by
  5) wait for 2 minutes
  6) wake the computer on
  7) wait for "network link established"
  8) click on "check mail" => ERROR POP-UP (the server rejected...)
  9) click on "check mail" => no error
(Reporter)

Comment 4

8 years ago
Created attachment 438364 [details]
log file of POP3 dialog with Thunderbird 3.0.4 for Linux
(In reply to comment #4)
> log file of POP3 dialog with Thunderbird 3.0.4 for Linux

Log looks last normal POP3 access before sleep/suspend.
Fllowing is log for first step of POP3 access.
> Entering NET_ProcessPop3 20
> POP3: Entering state: 1
> POP3: Entering state: 2
> POP3: Entering state: 4
> RECV: +OK Dovecot ready.
It look error before next "Entering NET_ProcessPop3 20" thru "+OK Dovecot ready"(connection with POP3 server completed). So, SMTP only log won't help.

Can you check NSPR log with next parameter?
> NSPR_LOG_MODULES=timestamp,POP3:5,nsHostResolver:5,nsSocketTransport:5
>  https://wiki.mozilla.org/MailNews:Logging
>  http://www.mozilla.org/projects/nspr/reference/html/prlog.html#25328
>  https://developer.mozilla.org/en/HTTP_Logging

Because nsSocketTransport:5 is specified, log file becomes huge. Please disable network access other than POP3 when getting NSPR log(disable checking of IMAP, News, RSS feeds, update check, ...). And, please don't attach log file without quick reading of log by yourself. Please attach log file after removing of irrelevant log lines(log lines of normal access before sleep/stanby, log lines after error to end of Tb, ...), please.
(Reporter)

Comment 6

8 years ago
I did that.

What happens is:
19:04:12 : Thunderbird started
19:04:13 : Automatic e-mail check
   (sent to standby)
19:13:08 : resuming from standby, automatic check
19:13:20 : after seeing "link established", I click on "check mail" => error
19:13:25 : click on "check mail" again => no error, I got a spam
(Reporter)

Comment 7

8 years ago
Created attachment 438526 [details]
Same thing, but with NSPR_LOG_MODULES=timestamp,POP3:5,nsHostResolver:5,nsSocketTransport:5

Comment 8

6 years ago
Is this still reproducible with latest builds?
(Reporter)

Comment 9

6 years ago
Non, I don't have this problem anymore in Seamonkey 2.3.3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Updated

6 years ago
Whiteboard: [Halloween2011Bug]
Version: unspecified → SeaMonkey 2.3 Branch
You need to log in before you can comment on or make changes to this bug.