OS X build of Thunderbird doesn't seem to respect IsPermaLink="false" in RSS feeds

RESOLVED INVALID

Status

MailNews Core
Feed Reader
--
major
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: skylerrabbit, Unassigned)

Tracking

Trunk
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a4pre) Gecko/20100327 Shredder/3.2a1pre

If I subscribe to an RSS feed with a GUID entry that contains IsPermaLink="false", Thunderbird under any OS X build I tried (3.0.3, latest Lanakila beta, and the latest shredder build above), the RSS parser seems to incorrectly insert the contents of the GUID field in as the 'website'. I could NOT reproduce this problem on a Windows build of Thunderbird 3.

http://cyber.law.harvard.edu/rss/rss.html#ltguidgtSubelementOfLtitemgt specifies:

'isPermaLink is optional, its default value is true. If its value is false, the guid may not be assumed to be a url, or a url to anything in particular.'

If you subscribe to the RSS feed in the URL blank, http://www.speedtv.com/rss/news, which does have an isPermaLink=false setup, you will find that the website links all come up as the contents of the GUID field with a '/' character tacked on the end.

Reproducible: Always

Steps to Reproduce:
1. Subscribe to http://www.speedtv.com/rss/news with a 3.x build.
2. Look at any of the articles pulled up, specifically at the resulting 'Website' attribute.
3. Example RSS code block below, followed by actual and expected results.
<item>
        <title>NHRA: McClenathan On Top At 4&#45;Wide Nationals</title>

        <link>http://auto-racing.speedtv.com/article/nhra-mcclenathan-on-top-at-4-wide-nationals/</link>
        <guid IsPermaLink="false">1040561</guid>
        <content:encoded><![CDATA[<img src="http://assets.speedtv.com/images/article_assets/104/1040561/1040561_article_img_med1.jpg" /><br />Cory McClenathan raced to the top of the pack in his Fram rail on day two of the NHRA 4-Wide Nationals at zMax Dragway, claiming his second No. 1 of the season.]]></content:encoded>
        <description>Cory McClenathan raced to the top of the pack in his Fram rail on day two of the NHRA 4&#45;Wide Nationals at zMax Dragway, claiming his second No. 1 of the season.</description>
        <dc:date>03/27/2010</dc:date>
        </item>

Actual Results:  
Actual 'website' which Thunderbird for OS X parses out of XML above, which is incorrect: 1040561/

Expected Results:  
Expected 'website' on the feed: http://auto-racing.speedtv.com/article/nhra-mcclenathan-on-top-at-4-wide-nationals/

This bug seems specific to OS X builds, and I imagine it happens on any RSS field with the isPermaLink=false specification. If I try this same feed on the Windows Thunderbird 3 build, it worked fine.
Component: Folder and Message Lists → Feed Reader
Product: Thunderbird → MailNews Core
QA Contact: folders-message-lists → feed.reader
Version: unspecified → Trunk
(Reporter)

Comment 1

8 years ago
After doing some messing about with the Windows version 3 build, I think I can now say that this bug applies to all platforms and not just the Mac. I'd confused a version 2 build with 3 on Windows which is why I reached the initial conclusion of 'Mac only'.
http://feedvalidator.org/check.cgi?url=http%3A%2F%2Fwww.speedtv.com%2Frss%2Fnews

We don't respect IsPermaLink because there is no such RSS attribute. We do, however, respect isPermaLink with a lowercase "i".
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.