Last Comment Bug 555509 - Clicking disable or enable in the detail view doesn't update the UI
: Clicking disable or enable in the detail view doesn't update the UI
Status: VERIFIED FIXED
[rewrite]
:
Product: Toolkit
Classification: Components
Component: Add-ons Manager (show other bugs)
: Trunk
: All All
: P1 normal (vote)
: mozilla1.9.3a5
Assigned To: Blair McBride [:Unfocused] (UNAVAILABLE)
:
: Andy McKay [:andym]
Mentors:
Depends on:
Blocks: 550048
  Show dependency treegraph
 
Reported: 2010-03-27 19:09 PDT by Dave Townsend [:mossop]
Modified: 2011-03-21 19:31 PDT (History)
4 users (show)
blair: in‑testsuite+
blair: in‑litmus-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
screenshot (188.50 KB, image/png)
2010-03-28 11:15 PDT, Dave Townsend [:mossop]
no flags Details

Description Dave Townsend [:mossop] 2010-03-27 19:09:45 PDT
If I go to the detail view of an add-on and click disable/enable nothing appears to happen. Going back to the list shows the change and an ugly progress-bar-like-thing.
Comment 1 Henrik Skupin (:whimboo) 2010-03-28 04:13:06 PDT
Dave, can you attach a screenshot?
Comment 2 Dave Townsend [:mossop] 2010-03-28 11:15:45 PDT
Created attachment 435474 [details]
screenshot
Comment 3 Henrik Skupin (:whimboo) 2010-03-28 11:32:25 PDT
Thanks Dave. That's already handled in bug 554245.

*** This bug has been marked as a duplicate of bug 554245 ***
Comment 4 Dave Townsend [:mossop] 2010-03-28 11:35:21 PDT
Bug 554245 makes no mention of the disable/enable button having no effect in the list view. That is the main issue here.
Comment 5 Blair McBride [:Unfocused] (UNAVAILABLE) 2010-04-19 18:47:27 PDT
http://hg.mozilla.org/projects/addonsmgr/rev/24f4f87cb241
Comment 6 Henrik Skupin (:whimboo) 2010-04-27 01:49:27 PDT
(In reply to comment #0)
> If I go to the detail view of an add-on and click disable/enable nothing
> appears to happen. Going back to the list shows the change and an ugly
> progress-bar-like-thing.

The broken status image is still present. I have filed bug 561982.
Comment 7 Dave Townsend [:mossop] 2010-05-11 11:57:47 PDT
Landed on trunk as a part of bug 554007
Comment 8 Henrik Skupin (:whimboo) 2010-05-14 17:52:03 PDT
I think that should be part of a broader test. I will create Litmus tests for all panes which will also cover this part. What about automation?

Verified fixed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100514 Minefield/3.7a5pre
Comment 9 Blair McBride [:Unfocused] (UNAVAILABLE) 2010-05-24 23:50:58 PDT
Yea, can be automated too. I think.
Comment 10 Henrik Skupin (:whimboo) 2011-03-08 13:40:16 PST
(In reply to comment #9)
> Yea, can be automated too. I think.

Blair, is that already covered meanwhile by an automated test?
Comment 11 Blair McBride [:Unfocused] (UNAVAILABLE) 2011-03-21 19:31:31 PDT
Covered in existing tests browser_list.js and browser_details.js - no need for a litmus test, IMO.

Note You need to log in before you can comment on or make changes to this bug.