Cannot keep track of when an extension becomes compatible

RESOLVED DUPLICATE of bug 294644

Status

()

Toolkit
Add-ons Manager
--
enhancement
RESOLVED DUPLICATE of bug 294644
8 years ago
8 years ago

People

(Reporter: A. Barsby, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a4pre) Gecko/20100327 Lightning/1.1a1pre Shredder/3.2a1pre

When trying to install a new extension, it will only install if compatible, which is as it should be. However, this means that users need to regularly check for compatibility. If an extension is already installed and becomes incompatible, the system automatically checks for when the extensions becomes compatible again. 
It would be useful if, when installing new extensions which were incompatible, they went into a "holding pattern" where they were not installed, but were added to the list to be checked for compatibility on start-up. That way, once an extension is updated to become compatible, the user would automatically be notified.

Reproducible: Always

Steps to Reproduce:
1. Try to install an incompatible extension which you would like to use once it is compatible.
2.
3.
Actual Results:  
The extension is not installed.

Expected Results:  
The extension should not be installed, but should be added to the watch list.
Component: Installer → Add-ons Manager
Product: Thunderbird → Toolkit
QA Contact: installer → add-ons.manager
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 294644
You need to log in before you can comment on or make changes to this bug.