Firefox trunk crashes on an HTML5 demo page [@ JS_TraceChildren]

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: pascalc, Unassigned)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(crash signature)

(Reporter)

Description

8 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a4pre) Gecko/20100328 Minefield/3.7a4pre

1/ go to http://apirocks.com/html5/html5_draft_slides.html
2/ use the arrow keyboard key as indicated
3/ wait ~30s -> Firefox crashes

Here are crash reports:

http://crash-stats.mozilla.com/report/index/bp-719b5b37-4055-41b8-9303-188f32100328

http://crash-stats.mozilla.com/report/index/bp-c59bb122-a9f7-469e-9d03-8730f2100328

http://crash-stats.mozilla.com/report/pending/daf33685-649a-4d01-bf3f-47d372100328

Comment 1

8 years ago
Signature	@0x0 | JS_TraceChildren
UUID	719b5b37-4055-41b8-9303-188f32100328
Time 	2010-03-28 10:09:52.451519
Uptime	50
Last Crash	57 seconds before submission
Product	Firefox
Version	3.7a4pre
Build ID	20100328032233
Branch	1.9.3
OS	Linux
OS Version	0.0.0 Linux 2.6.31-21-generic #59-Ubuntu SMP Wed Mar 24 07:28:56 UTC 2010 i686
CPU	x86
CPU Info	GenuineIntel family 6 model 23 stepping 6
Crash Reason	SIGSEGV
Crash Address	0x0
User Comments	http://apirocks.com/html5/html5_draft_slides.html
Processor Notes 	
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 		@0x0 	
1 	libmozjs.so 	JS_TraceChildren 	js/src/jsgc.cpp:1865
2 	libmozjs.so 	js_CallGCMarker 	js/src/jsgc.cpp:2141
3 	libmozjs.so 	js_TraceContext 	js/src/jsgc.cpp:2459
4 	libmozjs.so 	js_TraceRuntime 	js/src/jsgc.cpp:2492
5 	libmozjs.so 	js_GC 	js/src/jsgc.cpp:3156
6 	libmozjs.so 	js_NewFinalizableGCThing 	js/src/jsgc.cpp:1469
7 	libmozjs.so 	js_NewObjectWithGivenProto 	js/src/jsgc.h:278
8 	libmozjs.so 	js_NewObject 	js/src/jsobj.cpp:3010
9 	libmozjs.so 	TypedArrayTemplate<float>::class_constructor 	js/src/jstypedarray.cpp:632
10 	libmozjs.so 	js_CreateTypedArrayWithArray 	js/src/jstypedarray.cpp:1367
11 	libxul.so 	helper_nsICanvasRenderingContextWebGL_UniformMatrix_x_fv 	CustomQS_WebGL.h:581
12 	libmozjs.so 	js_Interpret 	js/src/jsops.cpp:2243
13 	libmozjs.so 	js_Invoke 	js/src/jsinterp.cpp:1372
14 	libmozjs.so 	js_InternalInvoke 	js/src/jsinterp.cpp:1429
15 	libmozjs.so 	JS_CallFunctionValue 	js/src/jsapi.cpp:4957
16 	libxul.so 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:2161
17 	libxul.so 	nsGlobalWindow::RunTimeout 	dom/base/nsGlobalWindow.cpp:8403
Assignee: nobody → general
Severity: major → critical
Component: General → JavaScript Engine
Keywords: crash
Product: Firefox → Core
QA Contact: general → general
Summary: Firefox trunk crashes on an HTML5 demo page → Firefox trunk crashes on an HTML5 demo page [@ JS_TraceChildren]
blocking2.0: --- → ?

Comment 2

8 years ago
still seeing this? I don't crash on it now.
blocking2.0: ? → betaN+

Comment 4

7 years ago
I am also unable repro (TM tip 19f70f8c2b88 debug linux build).
(In reply to comment #4)
> I am also unable repro (TM tip 19f70f8c2b88 debug linux build).

Wow, I love this demo. 

I also cannot reproduce in TM nightly.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ JS_TraceChildren]
You need to log in before you can comment on or make changes to this bug.