Nonexistent paths redirect unauthenticated users to homepage without notification

RESOLVED FIXED

Status

developer.mozilla.org
User management
P2
major
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: Kamil Sartys, Unassigned)

Tracking

Details

(Whiteboard: u=user c=wiki p=, URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2
Build Identifier: 

actually there are no non-existant paths on mdc because everything after https://developer.mozilla.org/ silently redirects to the homepage unless it exists. So one never knows: was that the page that i was intended to see. For example if s.o. sends you a shorted url that has become invalid in the meantime, you might not even notice the problem because there is no indication of a problem.

Reproducible: Always

Steps to Reproduce:
1.click on the url above
2.
3.
Actual Results:  
https://developer.mozilla.org/En will be shown

Expected Results:  
some intermediary page indicating a problem finding the correct path should be shown.
(Reporter)

Comment 1

8 years ago
I've got a better example which actually might be a bug of it's own.
Go to:
https://developer.mozilla.org/En/Documentation_hot_links
then click on the "Talk page"
https://developer.mozilla.org/Talk:En/Documentation_hot_links
you will be redirected to
https://developer.mozilla.org/En

it seems that this only works for talk pages which haven't been created yet. So maybe there should be no link. But then again it would be very hard to start a discussion.
This happens if you're not logged in. What's happening is it's trying to open the editor, but that fails because you're not logged in, and you get redirected to the main page since you're trying to enter a page you don't have access to.

We have a ticket filed with MindTouch requesting they add a "Would you like to log in so you can edit that page" page in this scenario though.

http://bugs.developer.mindtouch.com/view.php?id=7074

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 564750
Duplicate of this bug: 654322
This is the top issue on UserVoice.

When an authenticated user visits a nonexistent page, he is dropped into an edit form. When an unauthenticated user visits a nonexistent page, he is redirected to the homepage.

Please see the following UserVoice pages for the specifics of these requests:

* http://mdn.uservoice.com/forums/51389-mdn-website-feedback-http-developer-mozilla-org/suggestions/807215-missing-wiki-pages-redirect-unauthenticated-users-?ref=title
* http://mdn.uservoice.com/forums/51389-mdn-website-feedback-http-developer-mozilla-org/suggestions/805669-fix-the-redirects-?ref=title
* http://mdn.uservoice.com/forums/51389-mdn-website-feedback-http-developer-mozilla-org/suggestions/1058017-fix-the-broken-link-from-decodeuri-to-decodeuricom?ref=title
Severity: minor → major
Summary: non-existant paths redirect to mdc homepage without notification → Nonexistent paths redirect unauthenticated users to homepage without notification
Whiteboard: u=user c=wiki p=
Priority: -- → P2
This is a known "feature" of the MindTouch software. I do not believe there's anything we can do about it. We did file a bug report with MindTouch on it, but it has seen no movement.
Good to know. Thanks, Sheppy.

If nothing else, we should plan to fix this with Kuma.
Duplicate of this bug: 666571
(Assignee)

Updated

6 years ago
Component: Administration → User management
Product: Mozilla Developer Network → Mozilla Developer Network
Definitely fixed in Kuma. Woohoo!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.