Closed Bug 5557 Opened 21 years ago Closed 20 years ago

tables display like <br> for each data item

Categories

(Core :: Layout: Tables, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: ahatcher, Assigned: karnaze)

References

()

Details

Attachments

(2 files)

The tables on the web page show up as:
              caption
                 td
                 td
                 td
                ...
Instead of:
              caption
           td          td
           td          td

It might have to do with the fact that some of the <td> items
are <img src=xx.jpg>.
I tried removing the <center> around the tables and reloaded.
The graphic <td> entries turned into little left-justified dots.
So did the one at the top of the page.  Other <img>'s near the
bottom were intact.
Status: NEW → ASSIGNED
Target Milestone: M6
Hmm. Looking at this with 1999051109 & 1999050708, I see something
different: Nothing (except for the Amazon.com IMG at the top of the
page) -- i.e., the tables do not show up at all.

 In the attached test cases, this behaviour is driven by the <center>
tags that are wrapped around the table <caption>s. (First attachment:
with <center> => no tables; Second attachment: no <center> => visible
tables).
Moving to M8
Looking at this page with may28 win95 viewer: the problem I noted with table
captions and center tags is no longer reproducible (on the test cases or the
URL above).

I also don't see the problem noted in the original bug report.

In general, everything looks fine, but images do not always load successfully
(but it's opaque to me whether this is netlib/cache, or a
layout/reflow/loading problem).

Note: four of five images do not have height or width, so they all trigger
reflows, and on occasion, an image that has been successfully rendered will
subsequently disappear).
Moving to M9.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
This page loads beautifully in necko. I can't reproduce any of the problems
mentioned, so I'm marking this WORKSFORME.
Status: RESOLVED → VERIFIED
Verified Worksforme
You need to log in before you can comment on or make changes to this bug.