If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

not junk should override trust junk mail headers

RESOLVED DUPLICATE of bug 540385

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 540385
8 years ago
8 years ago

People

(Reporter: Mike Shultz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2) Gecko/20100207 Namoroka/3.6
Build Identifier: Thunderbird 3.0.3

When 'Trust junk mail headers' is set in preferences, it will always move messages from Inbox to Junk folders.  This happens even when explicitly marking something in the Junk folder as Not Junk.  Either the trust setting should only happen on the messages first download/viewing, or Not Junk should trump it.  

The only workaround I have is to move it to a subfolder and then mark it as not junk.

Reproducible: Always

Steps to Reproduce:
1. Download/view message with a spam system header(like SpamAssassin)
2. Mark it as not junk un Junk folder
3. View inbox and it will move it back to Junk
4. See same message in Junk
Actual Results:  
Message with SpamAssassin header always ends up back in Junk.

Expected Results:  
Left it in Inbox after I marked it as Not Junk
This looks a lot like bug 540385 -- can you confirm this, please, and mark this bug a duplicate of that one?
(Reporter)

Comment 2

8 years ago
It does appear to be the same thing.  I didn't see it since Product was set as 'MailNews Core'
(Reporter)

Comment 3

8 years ago
Let's try that again...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 540385
You need to log in before you can comment on or make changes to this bug.