If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

*BSD and GNU/Hurd support for libsydneyaudio

RESOLVED FIXED

Status

()

Core
Audio/Video
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
Created attachment 435840 [details] [diff] [review]
Patch

The current (mozilla) Makefile for libsydneyaudio doesn't support BSDs or GNU/Hurd, while the oss support file is present in the tree. The patch uses the oss support file on these platforms.
(Patch from Petr Salinger <Petr.Salinger@seznam.cz>)
(Assignee)

Updated

8 years ago
Attachment #435840 - Attachment is patch: true
Attachment #435840 - Attachment mime type: application/octet-stream → text/plain
Attachment #435840 - Flags: review?(benjamin)

Updated

8 years ago
Attachment #435840 - Flags: review?(benjamin) → review?(chris)
Comment on attachment 435840 [details] [diff] [review]
Patch

I'll have to take your word that it works on *BSD etc.
Attachment #435840 - Flags: review?(chris) → review+
Keywords: checkin-needed
(Assignee)

Updated

8 years ago
Assignee: nobody → mh+mozilla
(Assignee)

Updated

8 years ago
Status: NEW → ASSIGNED
Pushed patch to mozilla-central:
http://hg.mozilla.org/mozilla-central/rev/de5b841f2fdf

Thanks for the patch. Please reopen this bug if an up-to-date trunk build still isn't building on *BSD/Hurd.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Keywords: checkin-needed
You need to log in before you can comment on or make changes to this bug.