Firefox freezes on 2u.ee and spins in a 100% CPU loop, plugins disabled

RESOLVED DUPLICATE of bug 335256

Status

()

--
major
RESOLVED DUPLICATE of bug 335256
9 years ago
8 years ago

People

(Reporter: marti, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.2) Gecko/20100323 Namoroka/3.6.2
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.2) Gecko/20100323 Namoroka/3.6.2

When I visit the address http://www.2u.ee/eng/kalkulators_citizen_sld_311bk.html?3012.0.294
my Firefox 2.6.2 on Arch Linux completely locks up and I have to kill it. This occurs even with all browser plug-ins (Flash, Java etc) disabled.

Arch Linux basically ships the most recent version of all libraries. However, another person on Freenode #firefox also confirmed this problem on Ubuntu Karmic.


Reproducible: Always

Steps to Reproduce:
1. Visit http://www.2u.ee/eng/kalkulators_citizen_sld_311bk.html?3012.0.294
2. Spend a couple of seconds scrolling up and down.
3. The world is consumed by a black hole.
(Reporter)

Comment 1

9 years ago
Unfortunately this stack trace is not so useful because I don't have debug symbols for xulrunner, but these are thread stacks at the time of the freeze:

Thread 11 (Thread 0x7f642a8f2710 (LWP 4535)):
#0  0x00007f643a4f41c3 in poll () from /lib/libc.so.6
#1  0x00007f64395fa2cf in _pr_poll_with_poll () from /usr/lib/libnspr4.so
#2  0x00007f6438602a67 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#3  0x00007f6438602eee in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#4  0x00007f64386030f0 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#5  0x00007f6438dd6e3d in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#6  0x00007f6438dab9c1 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#7  0x00007f6438602c56 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#8  0x00007f6438dd6e93 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#9  0x00007f6438dab9c1 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#10 0x00007f6438dd74b8 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#11 0x00007f64395fe363 in _pt_root () from /usr/lib/libnspr4.so
#12 0x00007f643aca288a in start_thread () from /lib/libpthread.so.0
#13 0x00007f643a4fc9ed in clone () from /lib/libc.so.6
#14 0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7f6429ee8710 (LWP 4536)):
#0  0x00007f643aca710c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f64395f88ae in PR_WaitCondVar () from /usr/lib/libnspr4.so
#2  0x00007f64398f489c in ?? () from /usr/lib/xulrunner-1.9.2/libmozjs.so
#3  0x00007f64395fe363 in _pt_root () from /usr/lib/libnspr4.so
#4  0x00007f643aca288a in start_thread () from /lib/libpthread.so.0
#5  0x00007f643a4fc9ed in clone () from /lib/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f64296e7710 (LWP 4537)):
#0  0x00007f643aca7479 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f64395f7c79 in pt_TimedWait () from /usr/lib/libnspr4.so
#2  0x00007f64395f880c in PR_WaitCondVar () from /usr/lib/libnspr4.so
#3  0x00007f6438598808 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#4  0x00007f64395fe363 in _pt_root () from /usr/lib/libnspr4.so
#5  0x00007f643aca288a in start_thread () from /lib/libpthread.so.0
#6  0x00007f643a4fc9ed in clone () from /lib/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f64287ff710 (LWP 4538)):
#0  0x00007f643aca7479 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f64395f7c79 in pt_TimedWait () from /usr/lib/libnspr4.so
#2  0x00007f64395f880c in PR_WaitCondVar () from /usr/lib/libnspr4.so
#3  0x00007f6438dd9d8a in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#4  0x00007f6438dd6e93 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#5  0x00007f6438dab9c1 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#6  0x00007f6438dd74b8 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#7  0x00007f64395fe363 in _pt_root () from /usr/lib/libnspr4.so
#8  0x00007f643aca288a in start_thread () from /lib/libpthread.so.0
#9  0x00007f643a4fc9ed in clone () from /lib/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f6424af3710 (LWP 4541)):
#0  0x00007f643aca710c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f64395f88ae in PR_WaitCondVar () from /usr/lib/libnspr4.so
#2  0x00007f6438c28722 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#3  0x00007f64395fe363 in _pt_root () from /usr/lib/libnspr4.so
#4  0x00007f643aca288a in start_thread () from /lib/libpthread.so.0
#5  0x00007f643a4fc9ed in clone () from /lib/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f642353c710 (LWP 4542)):
#0  0x00007f643aca710c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f64395f88ae in PR_WaitCondVar () from /usr/lib/libnspr4.so
#2  0x00007f6438c29583 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#3  0x00007f64395fe363 in _pt_root () from /usr/lib/libnspr4.so
#4  0x00007f643aca288a in start_thread () from /lib/libpthread.so.0
#5  0x00007f643a4fc9ed in clone () from /lib/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f6422d3b710 (LWP 4543)):
#0  0x00007f643aca7479 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f64395f7c79 in pt_TimedWait () from /usr/lib/libnspr4.so
#2  0x00007f64395f880c in PR_WaitCondVar () from /usr/lib/libnspr4.so
#3  0x00007f643860b42c in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#4  0x00007f643860bc8c in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#5  0x00007f64395fe363 in _pt_root () from /usr/lib/libnspr4.so
#6  0x00007f643aca288a in start_thread () from /lib/libpthread.so.0
#7  0x00007f643a4fc9ed in clone () from /lib/libc.so.6
#8  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f6422334710 (LWP 4545)):
#0  0x00007f643aca710c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f64395f88ae in PR_WaitCondVar () from /usr/lib/libnspr4.so
#2  0x00007f64395f8926 in PR_Wait () from /usr/lib/libnspr4.so
#3  0x00007f6438dd6364 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#4  0x00007f6438dd6e73 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#5  0x00007f6438dab9c1 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#6  0x00007f6438dd74b8 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#7  0x00007f64395fe363 in _pt_root () from /usr/lib/libnspr4.so
#8  0x00007f643aca288a in start_thread () from /lib/libpthread.so.0
#9  0x00007f643a4fc9ed in clone () from /lib/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f6417eff710 (LWP 4546)):
#0  0x00007f643aca7479 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f64395f7c79 in pt_TimedWait () from /usr/lib/libnspr4.so
#2  0x00007f64395f880c in PR_WaitCondVar () from /usr/lib/libnspr4.so
#3  0x00007f64395f8926 in PR_Wait () from /usr/lib/libnspr4.so
#4  0x00007f6438dd862e in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#5  0x00007f6438dd6e93 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#6  0x00007f6438dab9c1 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#7  0x00007f6438dd74b8 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#8  0x00007f64395fe363 in _pt_root () from /usr/lib/libnspr4.so
#9  0x00007f643aca288a in start_thread () from /lib/libpthread.so.0
#10 0x00007f643a4fc9ed in clone () from /lib/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f64252f4710 (LWP 4547)):
#0  0x00007f643aca710c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f64395f88ae in PR_WaitCondVar () from /usr/lib/libnspr4.so
#2  0x00007f64395f8926 in PR_Wait () from /usr/lib/libnspr4.so
#3  0x00007f6438dd6364 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#4  0x00007f6438dd6e73 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#5  0x00007f6438dab9c1 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#6  0x00007f6438dd74b8 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#7  0x00007f64395fe363 in _pt_root () from /usr/lib/libnspr4.so
#8  0x00007f643aca288a in start_thread () from /lib/libpthread.so.0
#9  0x00007f643a4fc9ed in clone () from /lib/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f643b0a8720 (LWP 4534)):
#0  0x00007f643897a8ea in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#1  0x00007f6438989cdb in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#2  0x00007f6438989df2 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#3  0x00007f6438dd9395 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#4  0x00007f6438dd945f in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#5  0x00007f6438dd6e93 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#6  0x00007f6438dab9c1 in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#7  0x00007f6438d3154d in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#8  0x00007f6438c0884e in ?? () from /usr/lib/xulrunner-1.9.2/libxul.so
#9  0x00007f643857a3f2 in XRE_main () from /usr/lib/xulrunner-1.9.2/libxul.so
#10 0x0000000000402346 in ?? ()
#11 0x00007f643a44cb6d in __libc_start_main () from /lib/libc.so.6
#12 0x0000000000401af9 in ?? ()
#13 0x00007fff3b9f6da8 in ?? ()
#14 0x000000000000001c in ?? ()
#15 0x0000000000000001 in ?? ()
#16 0x00007fff3b9f8980 in ?? ()
#17 0x0000000000000000 in ?? ()
(Reporter)

Updated

9 years ago
Version: unspecified → 3.6 Branch

Comment 2

9 years ago
Confirmed

Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.3a4pre) Gecko/20100331 Minefield/3.7a4pre

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2

Disabling JS stops the run away ram and cpu usage. Disabling plugins does not. Looks to be a JS issue of some sort.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86_64 → All

Comment 3

9 years ago
Created attachment 437231 [details]
Compressed archive of the site

This is reproducible locally. The issue is with some code in main.js working on isolating what section.

Comment 4

8 years ago
Addition info on similar or identical bug. Hope it helps!
Thread using 96-96% CPU within Firefox 3.6.10
release info 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 ( .NET CLR 3.5.30729)

Running on Windows XP Pro 5.1.2600 service pack 3 build 2600

MS Process Explorer used to show threads and reveals that CPU attributed to -
firefox.exe+0x1840
i.e. it seems to  be in the base Firefox software, not an addon
Page example (occurs on lots of pages) was -
https://volunteer.london2012.com/portal/auth/portal/London2012/myGamesMakerJourney

Updated

8 years ago
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general
Version: 3.6 Branch → Trunk
The original site this was reported on has this JS:

	this.blink = function($item, $color1, $color2){
		if (this.$blinking.length == 0){
			window.setInterval("$main.blink()", 500);
		}

This causes a doubling in the number of running timers every 500ms.  That's bug 335256.

John, whatever you're seeing is a different issue....  at least assuming you see it on the login page I get when I load the url in comment 4.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 335256

Comment 6

8 years ago
(In reply to comment #5)
> The original site this was reported on has this JS:
> 
>     this.blink = function($item, $color1, $color2){
>         if (this.$blinking.length == 0){
>             window.setInterval("$main.blink()", 500);
>         }
> 
> This causes a doubling in the number of running timers every 500ms.  That's bug
> 335256.
> 
> John, whatever you're seeing is a different issue....  at least assuming you
> see it on the login page I get when I load the url in comment 4.
> 
> *** This bug has been marked as a duplicate of bug 335256 ***

Boris. Accepted. I now can't reproduce the fault consistently using that URL. My symptom probably arsies from a new bug or a different known bug. John
You need to log in before you can comment on or make changes to this bug.