Adding Hours Worked should not require a comment

RESOLVED DUPLICATE of bug 271913

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 271913
9 years ago
9 years ago

People

(Reporter: mrbball, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.13) Gecko/2009073021 Firefox/3.0.13
Build Identifier: 3.4.4

Currently, when adding to the Hours Worked field, a comment is required.
This does not make sense and it was apparently originally done this way
because individual hours worked is actually a field in the longdescs table
(work_time).

A comment should not be necessary to simply add hours worked.  Even though
work_time is in longdescs, it is possible to add an empty string as thetext
when inserting a record there.  If thetext is empty, you still get canned
text when the comment is displayed in the GUI:

  Additional hours worked: XXX

because the work_time is non-zero.

This is easily fixed by simply removing the lines in Bug.pm where
'comment_required' is thrown in add_comment() if the work_time is
non-zero and the comment text is empty.

I'm not sure, but the XML may need some tweaking in this case.  When I
display a bug that has work_time but no text in a comment, all I see the
following line:

<thetext/>

and no reference to the hours worked (although the work_time is displayed
as its own field).

Reproducible: Always

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 271913
You need to log in before you can comment on or make changes to this bug.