Crash when viewing web page

RESOLVED WORKSFORME

Status

()

Core
Layout
P3
critical
RESOLVED WORKSFORME
18 years ago
18 years ago

People

(Reporter: Erik Talvola, Assigned: clayton)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)
BuildID:    2000100508

Going to the URL in the report, Mozilla (or Netscape 6PR3) crashes.  Talkback 
doesn't seem to work through the firewall at work, so I don't think it was 
reported that way.

The Dr. Watson output is:

mozilla.exe
Exception: privileged instruction (0xc0000096), Address: 0x015241f4

Saving the file to disk (using IE 5.5) and then opening the saved version with 
Mozilla does NOT crash.  Only clicking on the URL causes the problem.


Reproducible: Always
Steps to Reproduce:
1. go to the URL.


Actual Results:  Mozilla crashes - Dr. Watson

Expected Results:  no crash							

let me know if it is not reproducable other places.

I tried it on an old Linux build (2000080923) and it worked fine.  

On Linux Netscape6 PR3 (don't have a new Mozilla handy), it works fine too.  I 
can only reproduce on NT.

Comment 1

18 years ago
I tried this with branch win2k, nt4 and win98 and trunk win2k but did not crash.
Was this a single incident or repeatable.

-> Layout, and marking Worksforme in the interim.
Assignee: trudelle → clayton
Component: XP Toolkit/Widgets → Layout
QA Contact: jrgm → petersen

Comment 2

18 years ago
worksforme, but reopen if this is consistently happening .
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

18 years ago
It happens all the time for me.  Tried it on my home machine - Win98 w/build 
2000092212 (I know it's old) and it happened too.  Have the McAfee tools 
installed and it dumped this out - not sure if it's useful.

Crash Protector Problem Report - Sunday, October 08, 2000 11:00:31 PM

User Description
================
viewing url

Fault Description
=================
D:\PROGRAM FILES\MOZILLA\SEAMONKEY\MOZILLA.EXE caused an
"Access Violation" fault in module Unknown 
at 017F:01E0B7D6.

Registers
=========
EAX=01E0B7CC CS=017F EIP=01E0B7D6 EFLGS=00010216
EBX=01DEF5C0 SS=0187 ESP=0068FAC4 EBP=0068FB10
ECX=01D6CB70 DS=0187 ESI=01174F38 FS=4B0F
EDX=0068F934 ES=0187 EDI=01E0B7CF GS=0000

Bytes at CS:EIP
===============
D6 B7 E0 01 7F 01 00 00 16 02 01 00 C4 FA 68 00 

Stack Dump
==========
0068FAC4: 601ED0EB 01D55F10 01DEF5C0 01E0B7CC
0068FAD4: 01174F40 00000003 00000002 01DEF5C4
0068FAE4: 00000000 601ED08E 00000000 01DEF4A0
0068FAF4: 00000000 0068FB94 00000000 00000000

32 bit Appications
==================
KERNEL32.DLL, C:\WINDOWS\SYSTEM\KERNEL32.DLL
KERNEL32.DLL, C:\WINDOWS\SYSTEM\KERNEL32.DLL
MPREXE.EXE, C:\WINDOWS\SYSTEM\MPREXE.EXE
PTUDFAPP.EXE, C:\WINDOWS\SYSTEM\PTUDFAPP.EXE
MSTASK.EXE, C:\WINDOWS\SYSTEM\MSTASK.EXE
BLACKD.EXE, C:\PROGRAM FILES\NETWORK ICE\BLACKICE\BLACKD.EXE
KERNEL32.DLL, C:\WINDOWS\SYSTEM\KERNEL32.DLL
EXPLORER.EXE, C:\WINDOWS\EXPLORER.EXE
RPCSS.EXE, C:\WINDOWS\SYSTEM\RPCSS.EXE
TASKMON.EXE, C:\WINDOWS\TASKMON.EXE
SYSTRAY.EXE, C:\WINDOWS\SYSTEM\SYSTRAY.EXE
EM_EXEC.EXE, C:\PROGRAM FILES\LOGITECH\MOUSEWARE\SYSTEM\EM_EXEC.EXE
CMGRDIAN.EXE, C:\PROGRAM FILES\NETWORK ASSOCIATES\MCAFEE SHARED 
COMPONENTS\GUARDIAN\CMGRDIAN.EXE
CMAGENT.EXE, C:\PROGRAM FILES\CYBERMEDIA\CMAGENT.EXE
NAVAPW32.EXE, C:\PROGRAM FILES\NORTON ANTIVIRUS\NAVAPW32.EXE
EN60PTB.EXE, C:\WINDOWS\SYSTEM\EN60PTB.EXE
DSSAGENT.EXE, C:\WINDOWS\BBSTORE\DSS\DSSAGENT.EXE
CTNOTIFY.EXE, C:\PROGRAM FILES\CREATIVE\SHAREDLL\CTNOTIFY.EXE
REALPLAY.EXE, D:\PROGRAM FILES\REAL\REALPLAYER\REALPLAY.EXE
WINAMPA.EXE, D:\PROGRAM FILES\WINAMP\WINAMPA.EXE
TSYSTRAY.EXE, D:\PROGRAM FILES\REAL\REALJUKEBOX\TSYSTRAY.EXE
DMHKEY.EXE, C:\PROGRAM FILES\DIAMOND\INCONTROL TOOLS 99\DMHKEY.EXE
RUNNER.EXE, D:\PROGRAM FILES\HYPNO\RUNNER.EXE
MEDIADET.EXE, C:\PROGRAM FILES\CREATIVE\SHAREDLL\MEDIADET.EXE
WMIEXE.EXE, C:\WINDOWS\SYSTEM\WMIEXE.EXE
FAMONHKW.EXE, C:\PROGRAM FILES\NETWORK ASSOCIATES\FIRST AID\FAMONHKW.EXE
FASMTMON.EXE, C:\PROGRAM FILES\NETWORK ASSOCIATES\FIRST AID\FASMTMON.EXE
RESMON.EXE, C:\PROGRAM FILES\NETWORK ASSOCIATES\FIRST AID\RESMON.EXE
FADSKMON.EXE, C:\PROGRAM FILES\NETWORK ASSOCIATES\FIRST AID\FADSKMON.EXE
CRASHMON.EXE, C:\PROGRAM FILES\NETWORK ASSOCIATES\FIRST AID\CRASHMON.EXE
FACPRMON.EXE, C:\PROGRAM FILES\NETWORK ASSOCIATES\FIRST AID\FACPRMON.EXE
KERNEL32.DLL, C:\WINDOWS\SYSTEM\KERNEL32.DLL
RNAAPP.EXE, C:\WINDOWS\SYSTEM\RNAAPP.EXE
TAPISRV.EXE, C:\WINDOWS\SYSTEM\TAPISRV.EXE
PSTORES.EXE, C:\WINDOWS\SYSTEM\PSTORES.EXE
DDHELP.EXE, C:\WINDOWS\SYSTEM\DDHELP.EXE
MOZILLA.EXE, D:\PROGRAM FILES\MOZILLA\SEAMONKEY\MOZILLA.EXE
CMCP32.EXE, C:\PROGRAM FILES\NETWORK ASSOCIATES\FIRST AID\CMCP32.EXE
IEXPLORE.EXE, C:\PROGRAM FILES\INTERNET EXPLORER\IEXPLORE.EXE
IEXPLORE.EXE, C:\PROGRAM FILES\INTERNET EXPLORER\IEXPLORE.EXE

Memory
======
Free USER Memory            :   58%
Free GDI Memory             :   85%
Memory Utilization          :   38%
Total Physical Memory       :   511 MB
Available Physical Memory   :   229 MB
Total Page File             :   256 MB
Available Page File         :   128 MB
Total Virtual Memory        :   2,044 MB
Available Virtual Memory    :   2,020 MB

Drives
======
A: - Removable
B: - Removable
C: - Fixed, 4,298 MB Total, 1,323 MB Free
D: - Fixed, 4,298 MB Total, 65 MB Free
E: - Fixed, 4,298 MB Total, 464 MB Free
F: - Fixed, 4,298 MB Total, 321 MB Free
G: - Removable
H: - CDROM
I: - CDROM

                       ****************

I'll try to kill off applications and see if it's interfering with something 
that I run at work and at home which causes the crash.

Comment 4

18 years ago
Works for me:
Platform: PC
OS: Windows 98
Build: 2000100904 M18 Trunk

Adding vbranch keyword.
Keywords: vbranch
(Reporter)

Comment 5

18 years ago
Can't reproduce the crash in the latest build (as of 8-NOV-2000).
You need to log in before you can comment on or make changes to this bug.