Closed Bug 556018 Opened 12 years ago Closed 12 years ago

category indication displayed incorrect in multiweek/month view and today pane

Categories

(Calendar :: Calendar Frontend, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ssitter, Assigned: Fallen)

References

Details

(Keywords: regression, Whiteboard: [needed beta][no l10n impact])

Attachments

(2 files)

Attached image screenshot of issue
Using Lightning 1.0b2pre (20100329) with Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.2pre) Gecko/20100330 Lanikai/3.1b2pre

Steps To Reproduce:
1. open Lightning preferecen dialog and assign a color to a category
2. create an event with this category
3. check display in multiweek or month view or today pane

Actual Results:
category indication is displayed incorrect with only 1 pixel height, see screenshot
Regression range: works in Lightning 1.0b2pre (20100324042445)
                  fails in Lightning 1.0b2pre (20100326042914)

Checkins during regression range: <https://hg.mozilla.org/comm-central/pushloghtml?startdate=2010-03-24+04:24:45&enddate=2010-03-26+04:29:14>
Flags: blocking-calendar1.0?
Flags: blocking-calendar1.0? → blocking-calendar1.0+
Duplicate of this bug: 556995
Attached patch Fix - v1Splinter Review
Attachment #440162 - Flags: review?(Mozilla)
This should take care. I'm sorry for adding another box, but I see no better way 
to align the task image in the center while keeping the category box the right
size.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Comment on attachment 440162 [details] [diff] [review]
Fix - v1

The patch works well in month and multiweek view, but a fix for the today pane is missing.
Comment on attachment 440162 [details] [diff] [review]
Fix - v1

Since the Today-Pane is not fixed with this patch,
r-
for now.
If we decide to defer this to another Bug, this patch is ok.
Attachment #440162 - Flags: review?(Mozilla) → review-
What exactly is not working for the today pane? I added an allday event and the category box is shown correctly.
Whiteboard: [needed beta][no l10n impact][needs feedback]
I messed it up with my comment#5 ... it definitely works as expected. I somehow thought we have a category indicator for non-allday events.
OS: Windows 7 → All
Hardware: x86 → All
Whiteboard: [needed beta][no l10n impact][needs feedback] → [needed beta][no l10n impact]
Attachment #440162 - Flags: review- → review+
Comment on attachment 440162 [details] [diff] [review]
Fix - v1

r=mschroeder
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/e7c67209e10b>
-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0b2
You need to log in before you can comment on or make changes to this bug.