IMAP/POP Mails are downloaded as corrupted 1K blank messages even though folders were compressed regularly

RESOLVED DUPLICATE of bug 387502

Status

MailNews Core
Backend
--
critical
RESOLVED DUPLICATE of bug 387502
8 years ago
8 years ago

People

(Reporter: worldtravel00, Unassigned)

Tracking

({dataloss})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2 (.NET CLR 3.5.30729)
Build Identifier: 3.0.4

IMAP/POP Mails are downloaded as corrupted 1K blank messages even though local email folders were compressed regularly. This happens occasionally and extremely annoying since my emails are forever lost. 

Here's the scenario:
- Have multiple emails accounts - IMAP and POPs.
- Regularly download emails to local email folders.
- Most of local email folders are 1GB+ or larger.
- Local inbox folders are kept at minimum usually less than 10MB each.
- Thunderbird automatically compresses the email folders.
- Manually compresses the email folders regularly.

Usually I notice at least once a week (no day correlations) that emails are getting corrupted while being downloaded to local drive. Thunderbird hangs when I'm trying to access the inbox after the download. I have to close the Thunderbird to access the inbox again. When I do, emails that were downloaded are corrupted as 1K blank subject/message line in the inbox folder.

Please fix this problem. This has been an issue since Thunderbird was launched !!! 

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1. Have a local mail folders with large sizes (1GB+)
2. Download mails from IMAP/POP mail accounts to local inbox folder
3. Mails are corrupted, and trying to open inbox foler hangs.
4. Thunderbird has to be closed in order to view the inbox.
Actual Results:  
emails are lost forever.

Expected Results:  
emails should be downloaded properly to local inbox folder.

It looks like it is occurring a lot if you have following:
- Large size (1GB+) mail folders on local drive
- Local Inbox folders are compressed regularly and automatically set to compress as a setup option.
- Perhaps slow Internet connections while downloading the emails.
Component: Folder and Message Lists → Backend
Keywords: dataloss
Product: Thunderbird → MailNews Core
QA Contact: folders-message-lists → backend
Does rebuilding the indexs help ?
What size are your mailboxes on disk ?
Do you use retention policy ?
(Reporter)

Comment 2

8 years ago
- Rebuilding indexes didn't help.
- Have 2 Local Mail folders that is 2.5GB+ and 5GB+. Have multiple sub folders that exceeds 300 MB+ each.
- No retention policy set and no plan to do so.
(In reply to comment #2)
> - Rebuilding indexes didn't help.
> - Have 2 Local Mail folders that is 2.5GB+ and 5GB+. Have multiple sub folders
> that exceeds 300 MB+ each.
> - No retention policy set and no plan to do so.

I think you've reached the limits of your Mail folders on disk. Which is where your issue might come from. 
Do you have some Anti-virus software ?
(Reporter)

Comment 4

8 years ago
What's the limit for Thunderbird mail folders? I though there wasn't as long as there's hard drive space. Using McAfee AntiVirus.
see here http://kb.mozillazine.org/Limits_-_Thunderbird

(I can't find similar article on official mozillamessaging KB)
(Reporter)

Comment 6

8 years ago
I see in the article, 4 GB is the limit and I'm suppose to get a error message saying 4GB is exceeded. However, I'm not getting any messages, and I'm able to continue adding new emails to the folders.
based on comment #6 this is a dupe of bug #387502 (repair info bug #387502 comment #107).

Feel free to reopen it if I'm wrong.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 387502
You need to log in before you can comment on or make changes to this bug.