Quote button reflows in table when clicked.

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
P3
normal
RESOLVED WORKSFORME
17 years ago
16 years ago

People

(Reporter: Chris Petersen, Assigned: dcone (gone))

Tracking

Trunk
Future
PowerPC
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm-], URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Build: 20000100608
Platform: Mac only.
Expected results: Applying focus to button should not button to reflow in table.
What I got: The button  moves below the input field.
Steps to reproduce: 

1) Go to http://lookup.netscape.com/lookup/Lookup.tibco?search=aol&st_symbol=on

2) Click on Quote button.

3) When focus is applied to button element, it reflows in the table.
(Reporter)

Comment 1

17 years ago
Nomiating RTM. 
Keywords: rtm
(Reporter)

Comment 2

17 years ago
Changing QA contact.
QA Contact: bsharma → petersen
(Reporter)

Comment 3

17 years ago
Created attachment 16420 [details]
Button is positioned next to input field
(Reporter)

Comment 4

17 years ago
Created attachment 16421 [details]
After focus has been palced on button;position is below field
(Reporter)

Comment 5

17 years ago
This doesn't occur on Oct 6th Win or Linux builds. Mac only issue.

Comment 6

17 years ago
don, can you take a look?
Assignee: rods → dcone
Marking rtm-. The page still functions. We'll need to look at this post RTM.
Whiteboard: [rtm-]
(Assignee)

Comment 8

17 years ago
Rod.. I think this has something to do with when the button is clicked in.. the 
size changes.. and causes a new reflow.  The size of the button is right on the 
hairy edge of going to the next line.. and I think it ends up being  a pixel or 
two difference in font size, outline size, something between the Mac and Windows 
and Linux.  I don't really know who is responsible for these issues, so I will 
give it back to you.. and you can forward it to the XPFE person who has the 
responsibility.
Assignee: dcone → rods

Comment 9

17 years ago
I noticed that this does this on WinNT for PR3, but not on the trunk build 
today or yesterday's branch. The main difference between PR3 and these builds is 
the font is now two points smaller.

waqar could you take a look and see if the button does actually get bigger?

To have it print out the size of the buttons during reflow remove the ifdef 
surrounding this macro at the bottom of the Reflow method:

 COMPARE_QUIRK_SIZE("nsGfxButtonControlFrame", 84, 24)
Assignee: rods → waqar

Updated

17 years ago
OS: All
Target Milestone: --- → Future

Comment 10

17 years ago
Since the site layout has changed this is a WFM.

This is probably a dupe of bug 72115?
bulk reassigning Waqar's bugs to Don.
Assignee: waqar → dcone
Page gone.  Probably dupe of bug 75632.  Resolving WFM.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.