Closed Bug 556200 Opened 12 years ago Closed 12 years ago

Add convenience method AddonManager.getAllAddons()

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla1.9.3a5

People

(Reporter: Unfocused, Unassigned)

References

Details

(Whiteboard: [rewrite][fixed by bug 555942])

As mentioned in bug 555942, the current (and only) way of getting all addons is to pass null to AddonManager.getAddonsByTypes(), which is a bit obscure. As such, it'd be nice to have a method dedicated to just getting all addons - AddonManager.getAllAddons(callback)
I actually did this in bug 565389 already
Status: NEW → RESOLVED
Closed: 12 years ago
Depends on: 555942
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a5
(In reply to comment #1)
> I actually did this in bug 565389 already

Dave, you probably meant another bug. Isn't this a dupe of bug 555942 now?
Version: unspecified → Trunk
No, just fixed as a part of it I think.
Right, it's:
http://hg.mozilla.org/mozilla-central/diff/2425e0fb812d/toolkit/mozapps/extensions/AddonManager.jsm

Anyway, it's fixed and we can mark it as verified.
Status: RESOLVED → VERIFIED
Whiteboard: [rewrite] → [rewrite][fixed by bug 555942]
Flags: in-testsuite-
Flags: in-litmus-
You need to log in before you can comment on or make changes to this bug.