Closed Bug 556251 Opened 12 years ago Closed 12 years ago

disk cache goes broken after using it long enough

Categories

(Core :: Networking: Cache, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 443067

People

(Reporter: syskin2, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a4pre) Gecko/20100330 Firefox/3.7a4pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a4pre) Gecko/20100330 Minefield/3.7a4pre

I found my Minefield not savibg anything in disk cache, and upon closer inspection, about:cache says this:

Number of entries: 	0
Maximum storage size: 	351200 KiB
Storage in use: 	393216 KiB

That is, cache is over capacity (so nothing gets in) and is empty (so nothing can be deleted).

Cache folder is like this:
31/03/2010  10:15 PM         5,868,323 _CACHE_001_
31/03/2010  10:15 PM         7,818,950 _CACHE_002_
31/03/2010  10:15 PM        23,086,852 _CACHE_003_
31/03/2010  10:15 PM           131,348 _CACHE_MAP_
               4 File(s)     36,905,473 bytes

No standalone files, and the three compound files (or whatever their names are) add up to one-tenth of reported size.

Reproducible: Couldn't Reproduce

Steps to Reproduce:
Simple tests with very small browser.cache.disk.capacity showed that expiration actually works fine...



I guess I see two problems here:
1. That cache database was maintained incorrectly and now its data simultaneously says it's empty and big
2. That cache system doesn't realise current cache database is inconsistent

It is the second time this problem happened, and I archived contents of Cache directory from both cases. First archive is dated 13/3/2010 so the problem appeared sometime before that date.

I can share both archived Cache directories on request, just not for public view (just in case; it does represent some of my browsing history after all).
Did you ever downloaded a file that is more than 351200 KiB (343MB, the maximum size of your cache) ?
Looks like a duplicate of bug 443067 if the answer to comment 1 is "yes".
(In reply to comment #1)
> Did you ever downloaded a file that is more than 351200 KiB (343MB, the maximum
> size of your cache) ?

It's perfectly possible that I did. Don't remember any, but yeah, possible.

I'll mark as duplicate as it's the most obvious explanation. Thanks, and apologies for not finding bug 443067 in my searches.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 443067
You need to log in before you can comment on or make changes to this bug.