Closed Bug 556311 Opened 10 years ago Closed 10 years ago

Explanatory animation not visible at about:firstrun, requires scrolling it in view

Categories

(Firefox for Android Graveyard :: General, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: d_jan, Assigned: mbrubeck)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: 1.9.2.3pre) / Fennec 1.1a2pre

The explanatory animation showing how to reveal the chrome is not in view since it appeares below the visible content. Therefore scrolling is required - but this is not discoverable too in some display ratios. (since the clip is not partly, but totally hidden)

Reproducible: Always

Steps to Reproduce:
1.open about:firstrun
2.click "take a Tour!"
3.You are likely not to see the clip
(4. Scroll down to see the clip)
Actual Results:  
I did not see the clip demonstrating how to reveal the chrome until I scrolled it in view.

Expected Results:  
The demonstration should be shown in a <div>-"window" (which can be closed) on top of the other page content or fennec should scroll the clip in view automatically.
Attached patch patchSplinter Review
Here's a one line patch to scroll the animation into view.

Tested only on desktop so far - I'm not sure if there might be timing issues if the image takes longer to load on the handset.
Assignee: nobody → mbrubeck
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #437327 - Flags: review?(mark.finkle)
Attachment #437327 - Flags: review?(mark.finkle) → review+
pushed:
http://hg.mozilla.org/mobile-browser/rev/7a1e2eb6ca2c
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
verified FIXED On builds:
Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2.4pre) Gecko/20100407 Namoroka/3.6.4pre Fennec/1.1a2pre

and

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.3a4pre) Gecko/20100407 Namoroka/3.7a4pre Fennec/1.1a2pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.