Closed Bug 556335 Opened 10 years ago Closed 10 years ago

nsHttpAuthEntry::Set behaves randomly if !ident and !mIdent.IsEmpty()

Categories

(Core :: Networking: HTTP, defect, trivial)

defect
Not set
trivial

Tracking

()

VERIFIED DUPLICATE of bug 557742

People

(Reporter: timeless, Assigned: timeless)

References

(Blocks 1 open bug, )

Details

(Keywords: coverity)

Attachments

(1 file)

386 nsHttpAuthEntry::Set(const char *path,
390                      const nsHttpAuthIdentity *ident,

418     nsresult rv;
419     if (ident) {
421     } 
422     else if (mIdent.IsEmpty()) {
423         // If we are not given an identity and our cached identity has not been
424         // initialized yet (so is currently empty), initialize it now by
425         // filling it with nulls.  We need to do that because consumers expect
426         // that mIdent is initialized after this function returns.
428     }
429     if (NS_FAILED(rv)) {
430         free(newRealm);
431         return rv;
432     }
Attached patch patchSplinter Review
Assignee: nobody → timeless
Status: NEW → ASSIGNED
Attachment #436238 - Flags: review?(cbiesinger)
Comment on attachment 436238 [details] [diff] [review]
patch

I'm sure that's not the correct behaviour.
Attachment #436238 - Flags: review?(cbiesinger) → review-
I guess I'll forward-dup this since the other bug has more explanation
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 557742
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.