Font-Face Render incorrectly & Strange in Non-English Fonts On Windows XP only. . .

RESOLVED WORKSFORME

Status

()

Core
Layout: Text
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Mohamed Shehab, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2
Build Identifier: Fireforx 3.6.x , Windows XP SP1/2/3

Font-face Works fine in the homepage of the site : http://www.misrnews.com/index.html
  but in all the inner pages it's broken (as you know in arabic language text is written from right to left and the Characters are joined to each other not splitted) . . . . please this issue needs someone who understands or at least knows how to read arabic , this issue happens only with Firefox 3.6.x on Windows XP doesn't happen on the same fireforx on Windows Vista / 7 

Reproducible: Always

Steps to Reproduce:
1.Open Firefox 3.6.x on Windows XP (Any build) 
2.goto http://www.misrnews.com/index.html (Font-Face will render correctly)
3.goto http://www.misrnews.com/sports.html (Font-Face will NOT render correctly)
Actual Results:  
you'll find the Arabic Letter Written as if each character in each word is an individual character not completing the other characters . . 

Expected Results:  
Expected result is to like just like it's rendered on the same version of Firefox on any other windows other than XP

I Tested it on multiple PCs & Laptops all give the same result . . .
(Reporter)

Updated

8 years ago
Summary: Font-Face Render incorrectly on Strange in Non-English Fonts . . . → Font-Face Render incorrectly & Strange in Non-English Fonts On Windows XP only. . .
Component: General → Layout: Text
Product: Firefox → Core
QA Contact: general → layout.fonts-and-text
Jonathan, can you take a look at this?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Yes, I see the issue. In fact, if you return to the homepage after seeing "broken" rendering on another page of the site, it can appear broken on index.html as well. Or zooming in and out may cause this to happen (the effect might not show up immediately due to cached textruns).

I suspect this is an XP Uniscribe problem - at some point when using that font (perhaps triggered by a particular character sequence) it is encountering an error, and "switching off" shaping for that font. Vista and Windows 7 have newer versions of Uniscribe, which could explain why they work more robustly.

(The above is currently a guess based on the observed behavior, not a proven theory. I'll see if I can identify more closely what's going wrong.)

I also tried the misrnews.com site with both IE6 and IE8 on Windows XP.... it crashed. It works OK with IE8 on Win7, however. I was also able to crash WordPad on XP by installing the Hacen Beirut Light font locally, and then using it and typing random Arabic-script characters into the document. This seems to support the idea that some problem in that particular font may be breaking XP's version of Uniscribe.
The version of Uniscribe (usp10.dll) on my XP system (SP2) is 1.420.2600.2180. As an experiment, I tried running Firefox 3.6.2 on that XP/SP2 machine, but with a newer Uniscribe DLL (1.626.6002.18005). With this version, I was unable to reproduce the problem; the downloaded Arabic font renders correctly, just as it does on more recent Windows versions.

So I'm pretty confident that this is a Uniscribe bug, perhaps in combination with a font error. Either there is a real flaw in the font, which can cause failures (up to and including application crashes) with the XP version of Uniscribe, while newer versions handle it more gracefully, or the font is technically OK but happens to trigger a bug in the older Uniscribe version.
(Reporter)

Comment 4

8 years ago
hmmm. . is there a way to fix this font or something ? It's already a free font 

can I do anything / or edit it using any font software such that it works ?
(Reporter)

Comment 5

8 years ago
O.K , Just Fixed it , I Believe the font is damaged or something I got another font very near to the one i was using from the same creator and now , FF on XP works Fine , IE6,7 don't Crash Anymore . . . Let This Font Goto Hell :D


Thanks to all who spent some time investigating my problem . . .
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(In reply to comment #5)
> O.K , Just Fixed it , I Believe the font is damaged or something I got another
> font very near to the one i was using from the same creator and now , FF on XP
> works Fine , IE6,7 don't Crash Anymore . . . Let This Font Goto Hell :D
> 
> 
> Thanks to all who spent some time investigating my problem . . .

Glad to hear your problem is resolved. I recommend that you report the issue to the creator of that font, so they can investigate and try to fix it; that could save other people from struggling with similar problems in the future.
You need to log in before you can comment on or make changes to this bug.