Closed Bug 556434 Opened 10 years ago Closed 4 months ago

Crash @ CWorker::_DoRecurringJobs on Windows Vista

Categories

(Core :: Audio/Video: Playback, defect, critical)

x86
Windows Vista
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: epinal99-bugzilla2, Unassigned)

References

()

Details

(Keywords: crash, reproducible, Whiteboard: [Vista])

Crash Data

Signature	TList<CMixer>::RemoveAt(void*)
UUID	1758896a-6f69-4405-9ab2-6889d2100331
Time 	2010-03-31 16:51:41.630916
Uptime	4203
Last Crash	788915 seconds before submission
Product	Firefox
Version	3.6.2
Build ID	20100316074819
Branch	1.9.2
OS	Windows NT
OS Version	6.0.6002 Service Pack 2
CPU	x86
CPU Info	GenuineIntel family 6 model 15 stepping 13
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0x0
User Comments	
Processor Notes 	
Related Bugs

Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	wdmaud.drv 	TList<CMixer>::RemoveAt 	
1 	wdmaud.drv 	CWorker::_DoRecurringJobs 	
2 	wdmaud.drv 	CWorker::_ThreadProc 	
3 	wdmaud.drv 	CWorker::_StaticThreadProc 	
4 	kernel32.dll 	BaseThreadInitThunk 	
5 	ntdll.dll 	__RtlUserThreadStart 	
6 	ntdll.dll 	_RtlUserThreadStart 	

Thread 30
Frame 	Module 	Signature [Expand] 	Source
0 	ntdll.dll 	KiFastSystemCallRet 	
1 	ntdll.dll 	NtWaitForSingleObject 	
2 	ntdll.dll 	RtlpWaitOnCriticalSection 	
3 	ntdll.dll 	RtlAddAccessAllowedAce 	
4 	wdmaud.drv 	CWorker::SubmitAndWait 	
5 	wdmaud.drv 	CWaveHandle::Reset 	
6 	wdmaud.drv 	wodMessage 	
7 	winmm.dll 	waveMessage 	
8 	winmm.dll 	waveOutReset 	
9 	msacm32.drv 	wodMessage 	
10 	winmm.dll 	waveMessage 	
11 	winmm.dll 	waveOutReset 	
12 	NPSWF32.dll 	NPSWF32.dll@0x1549c0 	
13 	NPSWF32.dll 	NPSWF32.dll@0xad264 	
14 	NPSWF32.dll 	NPSWF32.dll@0x154891 	
15 	NPSWF32.dll 	NPSWF32.dll@0x154add 	
16 	kernel32.dll 	BaseThreadInitThunk 	
17 	ntdll.dll 	__RtlUserThreadStart 	
18 	ntdll.dll 	WinSqmStartSession 	
19 	ntdll.dll 	_RtlUserThreadStart 	
20 	NPSWF32.dll 	NPSWF32.dll@0x154ad4 	
21 	NPSWF32.dll 	NPSWF32.dll@0x154ad4 	
Filename 	Version 	Debug Identifier 	Debug Filename
NPSWF32.dll 	10.0.45.2 	EF4B0B547B3349C898B243CC64A91FF61 	NPSWF32.pdb
Severity: normal → critical
Component: General → Plug-ins
Keywords: crash
Product: Firefox → Core
QA Contact: general → plugins
Version: unspecified → 1.9.2 Branch
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: plugins → adobe-flash
Version: 1.9.2 Branch → 10.x
Crash Signature: [@ TList<CMixer>::RemoveAt(void*) ]
bp-57aae22f-6829-44f4-a908-001a12120217
Thread 26 makes me think it's a video/audio bug.

More reports at:
https://crash-stats.mozilla.com/report/list?signature=TList%3CCMixer%3E%3A%3ARemoveAt%28void*%29
https://crash-stats.mozilla.com/report/list?signature=CWorker%3A%3A_DoRecurringJobs%28%29
Status: UNCONFIRMED → NEW
Crash Signature: [@ TList<CMixer>::RemoveAt(void*) ] → [@ TList<CMixer>::RemoveAt(void*)] [@ CWorker::_DoRecurringJobs()]
Component: Flash (Adobe) → Video/Audio
Ever confirmed: true
Keywords: reproducible
Product: Plugins → Core
QA Contact: adobe-flash → video.audio
Summary: Firefox 3.6.2 Crash [@ TList<CMixer>::RemoveAt(void*) ] → Crash @ CWorker::_DoRecurringJobs on Windows Vista
Version: 10.x → unspecified
The same TList<CMixer>::RemoveAt(void*) signature seems to be triggered by some users when playing the interactive version of http://www.google.com/doodles/zamboni
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #4)
> The same TList<CMixer>::RemoveAt(void*) signature seems to be triggered by
> some users when playing the interactive version of
> http://www.google.com/doodles/zamboni

Oh, and still Vista-specific there, FWIW.
I was on http://html5demos.com/two-videos where the crash happened its quite hard to reproduce but is out of blue.
It spiked (#36 top browser crasher in 19.0.2 over the last day) with Douglas Adams Birthday's Doodle: http://www.google.com/doodles/douglas-adams-61st-birthday

It doesn't crash for me but I am on Windows 7.
Whiteboard: [Vista]
Component: Audio/Video → Audio/Video: Playback
Crash Signature: [@ TList<CMixer>::RemoveAt(void*)] [@ CWorker::_DoRecurringJobs()] → [@ TList<CMixer>::RemoveAt(void*)] [@ CWorker::_DoRecurringJobs()] [@ TList<T>::RemoveAt] [@ CWorker::_DoRecurringJobs]

Closing because no crashes reported for 12 weeks.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.