Personas detail pages 404 when visited from /thunderbird

VERIFIED FIXED in 5.10

Status

P5
normal
VERIFIED FIXED
9 years ago
3 years ago

People

(Reporter: stephend, Assigned: wenzel)

Tracking

unspecified
5.10

Details

(Whiteboard: [z], URL)

STR:

1. Load https://preview.addons.mozilla.org/z/en-US/thunderbird/addon/64762/#reviews
2. Under "Other add-ons by nydile", on the right, click either of the "he-he..." add-ons

Actual Result:

https://preview.addons.mozilla.org/z/en-US/thunderbird/addon/86341/ is a 404

Expected Results:

Should be linking to the *Firefox* app-view of the add-on: https://preview.addons.mozilla.org/z/en-US/firefox/addon/86341/

(This is fine in Remora.)
Do we need to add an app parameter to reverse (and {% url %}) that lets us force a different app?
Let's roll this krupa-bug in with the [z] implementation if possible.
Priority: -- → P5
Summary: Pointing to the wrong application in "Other add-ons by" section, sometimes → [Add-on Details] Pointing to the wrong application in "Other add-ons by" section, sometimes
Target Milestone: --- → 5.10
This is working fine for me on a different author.  Example: https://preview.addons.mozilla.org/z/en-US/thunderbird/addon/10488/


I think this is something QA messed up behind the scenes and it's presenting as broken here.  Can someone confirm it's working on pages that aren't QA's?
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Wait; we don't know what's causing this, and, just because we can't re-reproduce it, we say it's fixed?  We should investigate; I haven't done anything intentional, to my knowledge, and even if I had, I don't see why or how that should result in a 404.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
QA has access to the admin sections of the site and, in the past, has changed a bunch of values there for their add-ons.  Sometimes that messes stuff up because the error checking there isn't the best.  If we can't reproduce this on any other add-ons that's what I assume happened.
(In reply to comment #0)

The real bug here is this:

> https://preview.addons.mozilla.org/z/en-US/thunderbird/addon/86341/ is a 404

I don't care if we have a redirect from thunderbird to firefox, but we should be able to find the application that will display that add-on.

Also, that's a persona, which should be supported by thunderbird.
Assignee: nobody → fwenzel
Status: REOPENED → NEW
Summary: [Add-on Details] Pointing to the wrong application in "Other add-ons by" section, sometimes → Personas detail pages 404 when visited from /thunderbird
(In reply to comment #5)
> QA has access to the admin sections of the site and, in the past, has changed a
> bunch of values there for their add-ons.  Sometimes that messes stuff up
> because the error checking there isn't the best.  If we can't reproduce this on
> any other add-ons that's what I assume happened.

So you're saying "the error checking there isn't the best" is a bug, but you're happy to mark this Fixed?  Doesn't make sense to me, but what do I know.
(Assignee)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
It's sad-making, but I can still repro.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 10

9 years ago
Really? The URL of this bug:

https://preview.addons.mozilla.org/z/en-US/thunderbird/addon/64762/#reviews

is everything but a 404 for me, though it was before I fixed it.

I'll look into the URL from comment 6 again though, which is an error 500 on both Firefox and Thunderbird. There might be another bug there.
(Assignee)

Comment 11

8 years ago
The bug here is fixed, but the remainder from comment 6 is apparently completely unrelated and a dupe of bug 559688 (as the traceback clouserw helped me obtain off preview suggests). Marking this a dependency.
Depends on: 559688
I can still reproduce the original bug from comment 0.
(Assignee)

Comment 13

8 years ago
(In reply to comment #6)
> (In reply to comment #0)
> 
> The real bug here is this:
> 
> > https://preview.addons.mozilla.org/z/en-US/thunderbird/addon/86341/ is a 404
> 
> I don't care if we have a redirect from thunderbird to firefox, but we should
> be able to find the application that will display that add-on.
> 
> Also, that's a persona, which should be supported by thunderbird.

It's not a persona, it's a search engine. Currently, we serve a 404 if an add-on type is invalid for the current app, but we redirect if the type is valid but the current version does not support this app. From a user point of view that makes limited sense. I'll cook up a patch that'll redirect in either case and only raise a 404 if there's nothing we can do.
(Assignee)

Comment 14

8 years ago
(In reply to comment #13)
> I'll cook up a patch that'll redirect in either
> case and only raise a 404 if there's nothing we can do.

I fixed this in http://github.com/jbalogh/zamboni/commit/a5c1687a38e4524011a9862ad4b6b5060f083fed .

Though on preview, it's not available altogether, it seems. Perhaps the DB is out of date?
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago8 years ago
Resolution: --- → FIXED
Verified FIXED; thanks, Fred (my original bug).
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.