If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Spellcheck should not check content on STYLE element in html messages

RESOLVED DUPLICATE of bug 222747

Status

()

Core
Spelling checker
RESOLVED DUPLICATE of bug 222747
8 years ago
8 years ago

People

(Reporter: Dave Royal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.2.2) Gecko/20100317 SUSE/3.6.2-1.2 Firefox/3.6.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1.9) Gecko/20100317 Thunderbird/3.0.4

I raised this following this question on Messaging support forum:
http://getsatisfaction.com/mozilla_messaging/topics/why_spell_check_the_markup_in_html_messages



Reproducible: Always

Steps to Reproduce:
1. Compose an html message with inline style in the sig or the message body, e.g.

<style type="text/css">
#sig { font-family : monospace ; }
</style>
<p id=sig>Dave</p>

I tried it as an html sig, and also used 'insert html' to put it in the message body.

2 Spellcheck the message.
Actual Results:  
'sig' and 'monospace' are flagged by the spellchecker

Expected Results:  
Should only spellcheck 'Dave'.

I've seen this mentioned several times on the forum. All the examples quoted are where people have included html generated by MS Office  - which might be a bad idea but should work /if/ the html is valid. 

Whether style elements are supposed to be valid in a sig or a message I don't know. HTML signature advice:
http://kb.mozillazine.org/Signatures_%28Thunderbird%29#HTML_signature_files
(If style elements are invalid I suggest that page should say so.)

Updated

8 years ago
Component: Message Compose Window → Spelling checker
Product: Thunderbird → Core
QA Contact: message-compose → spelling-checker

Comment 1

8 years ago
Created attachment 437960 [details]
Signature html file that gives spelling errors

Signature html file that gives spelling errors.
Created / edited with MS Word 2003 on Win XP.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.9) Gecko/20100317 Lightning/1.0b1 Thunderbird/3.0.4

Comment 2

8 years ago
Created attachment 437962 [details]
Signature html file that does not produce spelling errors

Signature html file that does not produce spelling errors.
Created with Nvu 1.0 on Win XP.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.9) Gecko/20100317 Lightning/1.0b1 Thunderbird/3.0.4

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 222747
You need to log in before you can comment on or make changes to this bug.