Fails to replace cloud data with local data at Start Over prompt

RESOLVED DUPLICATE of bug 548066

Status

Cloud Services
Firefox Sync: Backend
--
major
RESOLVED DUPLICATE of bug 548066
8 years ago
8 years ago

People

(Reporter: rastamanphan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2 (.NET CLR 3.5.30729)

Tried to use local data to replace cloud data. Followed all necessary steps in the Start Over sequence clicked replace existing data, confirmed replace, weave tried to sync client and reported an error. 

Reproducible: Always

Steps to Reproduce:
1. enter preferences and go to "start over" 
2. enter username & info
3. Set Weave to replace all data with local data.
4. error performing sync
Actual Results:  
weave provided a log of the event which is copied and pasted below in "additional information"

Expected Results:  
weave should have synced all local data to replace other data on existing devices.

verbose log follows:

2010-03-31 17:01:28	Service.Main         INFO	Logs reinitialized for service reset
2010-03-31 17:01:28	Service.Main         DEBUG	Clear cached values and take syncId: 87HD.zw~QV
2010-03-31 17:01:43	Net.Resource         DEBUG	GET success 200 https://sj-weave06.services.mozilla.com/1.0/UserName/storage/keys/pubkey
2010-03-31 17:01:43	Net.Resource         DEBUG	GET success 200 https://sj-weave06.services.mozilla.com/1.0/UserName/storage/keys/privkey
2010-03-31 17:01:43	Net.Resource         DEBUG	GET success 200 https://sj-weave06.services.mozilla.com/1.0/UserName/info/collections?v=1.1
2010-03-31 17:01:43	Net.Resource         DEBUG	GET success 200 https://sj-weave06.services.mozilla.com/1.0/UserName/storage/crypto/clients
2010-03-31 17:01:43	Engine.Clients       INFO	0 outgoing items pre-reconciliation
2010-03-31 17:01:43	Engine.Clients       INFO	Records: 0 applied, 0 reconciled, 0 left to fetch
2010-03-31 17:01:43	Engine.Clients       DEBUG	Total (ms): sync 183, processIncoming 2, uploadOutgoing 1, syncStartup 180, syncFinish 0
2010-03-31 17:01:43	Service.Main         DEBUG	Exception: Clients.getClients()[Clients.clientID] is undefined JS Stack trace: ()@service.js:1142 < WrappedNotify()@util.js:114 < WrappedLock()@util.js:86 < WrappedCatch()@util.js:65 < sync(false)@service.js:1080 < ([object Object])@service.js:401 < notify([object XPCWrappedNative_NoHelper])@util.js:637
2010-03-31 17:02:43	Service.Main         INFO	Logging out
(Reporter)

Comment 1

8 years ago
Created attachment 436508 [details]
Weave verbose log

this is the log provided by weave.

Comment 2

8 years ago
This should be fixed in the latest dev-channel version 1.2b2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 548066
You need to log in before you can comment on or make changes to this bug.