Status

MailNews Core
Composition
P3
minor
VERIFIED WONTFIX
17 years ago
9 years ago

People

(Reporter: BenB, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Reproduce:
1. Browse in Navigator
2. File|Send Link

Actual result:
HTML composer with body
<example>

http://www.example.com
</example>
Note the empty line. The URL is a link.

Expected result:
HTML composer with body
<example>
<http://www.example.com>
</example>
The URL, including angle brackets, is an URL.
During sending, the askSendFormat dialog must *not* come up.

Same for File|Send Page (but the askSendForamt dialog may come up in this case).
(Reporter)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0
(Reporter)

Updated

17 years ago
Summary: HTML question dialog comes up for Send Link → Tune Send Link
(Reporter)

Comment 1

17 years ago
Changing personal priorities. Giving away most of my bugs :-( (reassigning to
default owner).

I will still track these bugs closely. If you need my input, feel free to ask me.

New owner: Please do *not* close these bugs (as WONTFIX or whatever you may
find) unless they are fixed. Rather, reassign to <nobody@mozilla.org>, if you
don't want to work on them.
Assignee: mozilla → ducarroz
Status: ASSIGNED → NEW
Target Milestone: mozilla1.0 → ---

Comment 2

17 years ago
Most often you want to make a comment to the link, or at least write "Hi" before
sending. I think this linefeed is on purpose, it's not a bug - it's a feature! :)

Seriously though, this is a clear wontfix. It would just be more hassle for most
users to press <enter> every time they sent a link to make a comment.
(Reporter)

Comment 3

17 years ago
The comment is supposed to go *after* the link - the mail is about the webpage,
so the link should be in the first line, i.e. at the very top.
(Reporter)

Comment 4

17 years ago
BTW: That's the way 4.x works.
Keywords: 4xp
(Assignee)

Comment 5

16 years ago
We put an empty line else there is no way to type text before the link whitout
beeing part of it.

When you send the message, as long you don't enter yourself some rich
formatting, the ask me dialog does not come up.

We put the angle brackets only when you are setup to use plain text composition.
The only potential problem I see is that when we translate from HTML to
plaintext during the send operation, we are not putting the link between angle
brackets! If you really think we should do that, plaease file a new bug.

I don't know how to resolve this bug: should be a won't fix, a WFM or invalid!
ANyway, I'll use Won't fix to avoid QA to waste time on it trying to figure what
to do with it...
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 6

16 years ago
.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.