Closed Bug 556604 Opened 11 years ago Closed 10 years ago

portrait mode - notification bars are too wide

Categories

(Firefox for Android Graveyard :: General, defect)

Fennec 1.1
ARM
Maemo
defect
Not set
normal

Tracking

(fennec1.1+)

VERIFIED FIXED
Tracking Status
fennec 1.1+ ---

People

(Reporter: madhava, Assigned: mfinkle)

Details

(Whiteboard: [fennec l10n][l10n], qablocker)

Attachments

(1 file, 1 obsolete file)

tracking-fennec: --- → ?
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 520786
not a dupe. bug 520786 is about font size in larry. this bug is about the button size in the notification.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: portrait mode - notification bars are two wide → portrait mode - notification bars are too wide
The "Never for This Site" text is forcing the notification buttons to overflow
Attached patch patch (obsolete) — Splinter Review
This patch:
* Changes "Never for This Site" to "Never"
* Removes the access keys so we don't see underlined letters in the notification buttons
Assignee: nobody → mark.finkle
Attachment #436745 - Flags: review?(21)
The patch overrides the toolkit passwordmgr.properites file, but only changes the following keys:

notifyBarNotNowButtonAccessKey =
notifyBarNeverForSiteButtonText = Never
notifyBarNeverForSiteButtonAccessKey =
notifyBarRememberButtonAccessKey =
notifyBarChangeButtonAccessKey =
notifyBarDontChangeButtonAccessKey =
Attached patch patch 2Splinter Review
Same as last patch, but this patch adds a change to the notification box structure. It puts the close button (the red X) in the same row as the description text, instead of outside of the description text and buttons.

This means that the buttons are the primary elements to control the width of the notification box. The previous patch displayed the buttons fine, but part of the close button was overflowed. This patch allows all elements to be visible in portrait.
Attachment #436745 - Attachment is obsolete: true
Attachment #436753 - Flags: review?(21)
Attachment #436745 - Flags: review?(21)
Comment on attachment 436753 [details] [diff] [review]
patch 2

I'm a bit afraid of the strings change, but since portrait mode is really a huge improvement for Firefox Mobile I think it is rational to allow them.
Attachment #436753 - Flags: review?(21) → review+
Stuart, Pike: this is a late breaking string change. We won't land it until we get approval.
Whiteboard: [fennec l10n][l10n]
I don't think we should take this now.

If it's bad enough to fix we could possibly fix it between beta and RC, but then we should have a really extensive documentation of what's the difference between the overload and the original file.
Keywords: qablocker
OS: Mac OS X → Linux (embedded)
Hardware: x86 → ARM
Keywords: qablocker
Whiteboard: [fennec l10n][l10n] → [fennec l10n][l10n], qablocker
tracking-fennec: ? → 1.1+
pushed:
http://hg.mozilla.org/mobile-browser/rev/d873024abebd

(not for beta 1, just for rc)
Status: REOPENED → RESOLVED
Closed: 11 years ago10 years ago
Resolution: --- → FIXED
Verifixed fixed, using:
Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:1.9.3a5pre) Gecko/20100420 Namoroka/3.7a5pre Fennec/1.1a2pre
Status: RESOLVED → VERIFIED
Is this ok? 

+showPasswordsAccessKey=P

All other access keys were left empty.
(In reply to comment #12)
> Is this ok? 
> 
> +showPasswordsAccessKey=P
> 
> All other access keys were left empty.

It's OK. It looks like showPasswordsAccessKey is only used in the PasswordManager dialog, which Fennec does not use. I wanted to minimize the changes to the file, so I only changed things that show up in Fennec UI.

Thanks for checking. I don't like to see access keys in the Fennec UI, so any we can remove is a good thing.
You need to log in before you can comment on or make changes to this bug.