portrait mode - viewport device-width pages do not resize when changing orientation

VERIFIED FIXED

Status

Firefox for Android Graveyard
General
VERIFIED FIXED
8 years ago
5 years ago

People

(Reporter: madhava, Assigned: mfinkle)

Tracking

Fennec 1.1
x86
Mac OS X

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Switching from landscape to portrait:
http://www.flickr.com/photos/madhava_work/4482692088/

After switching from portrait to landscape:
http://www.flickr.com/photos/madhava_work/4482147088/


Other sites I've tried seem fine.

I haven't tried with other "about:" pages.
(Reporter)

Updated

8 years ago
tracking-fennec: --- → ?
This is a bug with <meta name="viewport" content="width=device-width"/>
Summary: portrait mode - Firefox Start page doesn't transition well between landscape and portrait → portrait mode - viewport device-width pages do not resize when changing orientation
Created attachment 436725 [details] [diff] [review]
patch

This patch adds a way to know if the viewport width or height is set to "device-*"

If it is, we use the "window-width" and "window-height" CSS classes to auto size the page during resizes.

The patch also adds a rule I found on the apple docs:
* If the initi-scale = 1.0 and the width is not set, make the width "device-width"
Assignee: nobody → mark.finkle
Attachment #436725 - Flags: review?(bugmail)
(Assignee)

Updated

8 years ago
Duplicate of this bug: 556822
Attachment #436725 - Flags: review?(bugmail) → review+
pushed:
http://hg.mozilla.org/mobile-browser/rev/b4cf3d9007c5
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
veirfied FIXED on builds:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2.4pre) Gecko/20100405 Namoroka/3.6.4pre Fennec/1.1a2pre

and

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.3a4pre) Gecko/20100405 Namoroka/3.7a4pre Fennec/1.1a2pre
Status: RESOLVED → VERIFIED
Duplicate of this bug: 541094
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.