If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Don't show any context menu if the webpage cancels "contextmenu"

RESOLVED INVALID

Status

Fennec Graveyard
General
RESOLVED INVALID
8 years ago
7 years ago

People

(Reporter: aakashd, Unassigned)

Tracking

Fennec 1.1

Details

(Reporter)

Description

8 years ago
Build Id:
Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2.3pre) Gecko/20100401 Namoroka/3.6.3pre Fennec/1.1a2pre

Steps to Reproduce:
1. Go to maps.google.com
2. Tap and hold down on the map

Actual Results:
The context menu comes up with the save image option

Expected Results:
Since it's not an image, the save image option (and ultimately the context menu) shouldn't pop-up.
It _is_ an image, so the code is working as designed. You could say that since Google Maps tries to override the context menu (as it does on desktop) we should not show our context menu - but that is a different bug.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

8 years ago
Well, that's kinda where I was going with this. Can't we just use this bug and mention that it should match the behavior on desktop firefox?
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
I don't think we should show the webpage's context menu. But we could look into just displaying no context menu at all (even our own).

I don't see this as blocking though
Summary: long click on google maps brings up context menu with save image option → Don't show any context menu if the webpage cancels "contextmenu"
Madhava - Do we want the webpage to be able to cancel our contextmenu? With so much functionality, especially "sharing" - I say no.
tracking-fennec: ? → 2.0-
We are not doing this for 2.0. Our context menus take priority for now
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.