Some flash elements does not load when page is invisible or minimized

RESOLVED INCOMPLETE

Status

()

Firefox
General
RESOLVED INCOMPLETE
8 years ago
7 years ago

People

(Reporter: Rasputin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-2-25])

Attachments

(1 attachment)

617.84 KB, application/octet-stream
Details
(Reporter)

Description

8 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; GTB0.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; ru; rv:1.9.2) Gecko/20100115 Firefox/3.6

The problem is when you minimize page or make him invisible when loading, some flash elements like online video wouldn't load/activates at all. Internet Explorer has no such problems.

Here is excample

<html>
<body>

<object id="playerID" codetype="application/x-shockwave-flash" height="100%" width="100%">
<param name="movie" value="http://rutube.ru/player.swf">
<param name="wmode" value="opaque">
<param name="allowFullScreen" value="true">
<param name="allowScriptAccess" value="always">
<param name="flashVars" value="buffer_first=1.0&amp;file=http%3A%2F%2Fbl.rutube.ru%2F85fb9e8e9f63e2e6b8623d4552991282.iflv&amp;xurl=http%3A%2F%2Frutube.ru%2Ftrackinfo%2F85fb9e8e9f63e2e6b8623d4552991282.html%3Fad_ids%3D&amp;image=http%3A%2F%2Fimg-1.rutube.ru%2Fthumbs%2F85%2Ffb%2F85fb9e8e9f63e2e6b8623d4552991282-1.jpg&amp;&amp;autoload=true&amp;fsb=true&amp;logo=false&amp;newWnd=false&amp;rAngle=0&amp;uid=609833&amp;referer=http%3A//rutube.ru/tracks/3090638.html%3Fv%3D85fb9e8e9f63e2e6b8623d4552991282">
<embed src="3090638_files/player.swf" 
flashvars="autoPlay=1&buffer_first=1.0&amp;file=http%3A%2F%2Fbl.rutube.ru%2F85fb9e8e9f63e2e6b8623d4552991282.iflv&amp;xurl=http%3A%2F%2Frutube.ru%2Ftrackinfo%2F85fb9e8e9f63e2e6b8623d4552991282.html%3Fad_ids%3D&amp;image=http%3A%2F%2Fimg-1.rutube.ru%2Fthumbs%2F85%2Ffb%2F85fb9e8e9f63e2e6b8623d4552991282-1.jpg&amp;&amp;autoload=true&amp;fsb=true&amp;logo=false&amp;newWnd=True&amp;rAngle=0&amp;uid=609833&amp;referer=http%3A//rutube.ru/tracks/3090638.html%3Fv%3D85fb9e8e9f63e2e6b8623d4552991282
 " type="application/x-shockwave-flash" wmode="opaque" allowscriptaccess="always" name="playerID" allowfullscreen="true" height="100%" width="100%"></object>


</body></html>

Reproducible: Always

Steps to Reproduce:
1. Make HTML page and copy excample
2. Load this html into FF and Instantly minimize or go to another tab
3. Wait some time
Actual Results:  
You will see that flash will load only when page has been visually activated


All configuration is default, and this bug has been detected even in Gecko 1.9.1
(Reporter)

Comment 1

8 years ago
Here is more clear excample:


<html>
<body>

<script type="text/javascript">
function ShowPlayer() {
document.write('<object id="playerID" codetype="application/x-shockwave-flash" height="100%" width="100%">');
document.write('<param name="movie" value="http://rutube.ru/player.swf">')
document.write('<param name="wmode" value="opaque">')
document.write('<param name="allowFullScreen" value="true">')
document.write('<param name="allowScriptAccess" value="always">')
document.write('<param name="flashVars" value="buffer_first=1.0&amp;file=http%3A%2F%2Fbl.rutube.ru%2F85fb9e8e9f63e2e6b8623d4552991282.iflv&amp;xurl=http%3A%2F%2Frutube.ru%2Ftrackinfo%2F85fb9e8e9f63e2e6b8623d4552991282.html%3Fad_ids%3D&amp;image=http%3A%2F%2Fimg-1.rutube.ru%2Fthumbs%2F85%2Ffb%2F85fb9e8e9f63e2e6b8623d4552991282-1.jpg&amp;&amp;autoload=true&amp;fsb=true&amp;logo=false&amp;newWnd=false&amp;rAngle=0&amp;uid=609833&amp;referer=http%3A//rutube.ru/tracks/3090638.html%3Fv%3D85fb9e8e9f63e2e6b8623d4552991282">')
document.write('<embed src="3090638_files/player.swf" flashvars="autoPlay=1&buffer_first=1.0&amp;file=http%3A%2F%2Fbl.rutube.ru%2F85fb9e8e9f63e2e6b8623d4552991282.iflv&amp;xurl=http%3A%2F%2Frutube.ru%2Ftrackinfo%2F85fb9e8e9f63e2e6b8623d4552991282.html%3Fad_ids%3D&amp;image=http%3A%2F%2Fimg-1.rutube.ru%2Fthumbs%2F85%2Ffb%2F85fb9e8e9f63e2e6b8623d4552991282-1.jpg&amp;&amp;autoload=true&amp;fsb=true&amp;logo=false&amp;newWnd=True&amp;rAngle=0&amp;uid=609833&amp;referer=http%3A//rutube.ru/tracks/3090638.html%3Fv%3D85fb9e8e9f63e2e6b8623d4552991282 " type="application/x-shockwave-flash" wmode="opaque" allowscriptaccess="always" name="playerID" allowfullscreen="true" height="100%" width="100%">')
document.write('</object>')
}
var t=setTimeout('ShowPlayer()',3000);

</script>
</body></html>
Please attach a testcase using "add an attachment" and not as comment and please never compare IE (ActiveX plugins) with other browsers (npapi plugins).
(Reporter)

Comment 3

8 years ago
Created attachment 436847 [details]
Test page

Zip archive, with html page. Where after 3 seconds will display flash element.

Comment 4

8 years ago
Duplicate of bug 494104 comment 1?
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2011-2-25]
This bug has had the CLOSEME tag for several weeks and the date in the tag is
far gone. If the reporter can still see this issue, Please retest with Firefox
3.6.x or later and a new profile
(http://support.mozilla.com/kb/Managing+profiles). Then please remove the
closeme tag in the whiteboard, mark the bug against the proper version and
comment on the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.