If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Can't switch between certain windows via Tasks menu

VERIFIED DUPLICATE of bug 21296

Status

SeaMonkey
UI Design
P3
normal
VERIFIED DUPLICATE of bug 21296
17 years ago
9 years ago

People

(Reporter: Adam, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
PowerPC
All

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla M18 2000100608 -

1) Open the Find in This Page window or the Page Info window
2) Try to switch to the browser window by selecting it in the Tasks menu

You're unable to switch between the windows via the Tasks menu. I'm not sure if
this is a problem with these specific windows or with the type of windows, etc.
Since the windows can be moved to the background by clicking on the browser
window, you should be able to do this via the Tasks menu as well.

Note: The Find window is more like a dialog (no close/resize widgets) so it
might be that you're not supposed to be able to move it to the backgound at all.
(Reporter)

Comment 1

17 years ago
See also bug 49015 - unable to switch between save dialogs via Tasks menu.

Comment 2

17 years ago
Adam Kay, do you still see this with a recent build? For me, the "Find in this
Page" dialog cannot be moved to the background, and it is supposed to work that
way. The "Page Info" dialog doesn't have a Tasks menu, so there is no issue
about this dialog. Any other example? If not, i'll just mark this wontfix or
worksforme, depending on your answer. Thank you,
Fabian.
OS: All
(Reporter)

Comment 3

17 years ago
When I last checked, this behavior was still present. You can switch to another
window from the "Find in This Page" dialog by clicking on any window behind it.
The Tasks dialog doesn't allow you to achieve this for the Find dialog, so the
former behavior might be the real bug (if you shouldn't be able to move the Find
dialog into the background at all). Also, AFAIK, the Page Info window is indeed
a window (on Mac builds, at least) that contains a functional Tasks menu.

If it turns out that these elements are not supposed to be able to be moved into
the background, then a new bug should be filed and this one closed. I'm just
waiting for an official word on the expected behavior (which, with bugs filed
under "Platform: Macintosh," could take some time).

Comment 4

17 years ago
CC'ing Pinkerton for mac stuff.
Fabian.
(Reporter)

Comment 5

17 years ago
2000112608 build - Page Info and Find in This Page windows can be moved to the
background by clicking on an open browser window but you are unable to switch
between windows via the Tasks menu. If a browser window is in the foreground,
they can be made active using the Tasks menu. So the problem is either the Tasks
menu is screwing up when these windows are in front, or you're not supposed to
be able to move these windows into the background.
sounds like z-ordering event problems. cc'ing danm (and rubbing him all over
with my germ infested hands).

Comment 7

17 years ago
  Oh. This is another aspect of the interaction betwee our Window-specific main 
menu and dialogs. The problem is, our architecture favors platforms which 
associate the menubar with the window: every platform but the Mac. Our current 
rather unhappy solution is to leave untouched the last menubar when a window 
without a menubar comes up.
  The Find Dialog doesn't have an associated menubar, so it has this problem. 
You'll notice that no menu selections made from the menubar work with the Find 
Dialog. Not the Tasks Menu. Not the View Menu. Not even the Edit Menu. Nothing.
  Closing as a dupe of saari's long-standing "(modal) dialogs break the menubar" 
bug.


*** This bug has been marked as a duplicate of 21296 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
mass verification of duplicate bugs: to find all bugspam pertaining to this, set
your search string to "DuplicateBugsBelongInZahadum".

if you think this particular bug is *not* a duplicate, please provide a
compelling reason, as well as check a recent *trunk* build (on the appropriate
platform[s]), before reopening.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.