Searching for NS_DECL_NSISUPPORTSWEAKREFERENCE and NSISUPPORTSWEAKREFERENCE yield different results

RESOLVED WORKSFORME

Status

P3
major
RESOLVED WORKSFORME
9 years ago
2 years ago

People

(Reporter: jdm, Assigned: carlos)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
More than the obvious difference in results, no uses of NS_DECL_NSISUPPORTSWEAKREFERENCE show up in the first search, whereas they do in the second.
Can you give the url for what you're doing/seeing?  Also note that we don't record callers/users of macros, since the macros are gone by the time the compiler/analysis gets the code for indexing.  I just have a hack on the preprocessor to extract macro defs:

http://scotland.proximity.on.ca/dxr/search.cgi?tree=mozilla-central&macro=NS_DECL_NSISUPPORTSWEAKREFERENCE
(Reporter)

Comment 2

9 years ago
Note how searching for the string NS_DECL_NSISUPPORTSWEAKREFERENCE shows no results: http://scotland.proximity.on.ca/dxr/search.cgi?tree=mozilla-central&string=NS_DECL_NSISUPPORTSWEAKREFERENCE

Then, note how searching for the string NSISUPPORTSWEAKREFERENCE contains uses of NS_DECL_NSISUPPORTSWEAKREFERENCE: http://scotland.proximity.on.ca/dxr/search.cgi?tree=mozilla-central&string=NSISUPPORTSWEAKREFERENCE

Comment 3

6 years ago
Assigning it to Carlos as it is a search issue
Assignee: nobody → carlos
Severity: normal → major
Status: NEW → ASSIGNED
Priority: -- → P4

Updated

6 years ago
Priority: P4 → P2

Updated

6 years ago
Priority: P2 → P3
(Reporter)

Comment 4

2 years ago
The problem described no longer reproduces.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.