Firefox 3.5.9 and 3.6.3 seem to think it has compatibility problems with certain Add-ons

RESOLVED DUPLICATE of bug 547708

Status

()

Toolkit
Add-ons Manager
RESOLVED DUPLICATE of bug 547708
8 years ago
8 years ago

People

(Reporter: Todd, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.9) Gecko/20100315 Firefox/3.5.9 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.9) Gecko/20100315 Firefox/3.5.9 (.NET CLR 3.5.30729)

Firefox 3.5.9 and 3.6.3 seem to think it has compatibility problems. 

Every day it disables the four (4) add-ons/extensions Listed at the end of this message. 

Click on Update Add-ons and everything works fine...until the next day when it happens all over again....

It happens on two different PC's .. one is Windows XP and one is Vista.

I tried both versions of Firefox mentioned above, on both machines, and ONLY THE OLD VERSION 3.5.8 WORKS PROPERLY

I have a number of add-ons/extensions and all work fine on 3.5.9 / 3.6.3 , except for the four (4) listed below ... If I reinstall and go back to 3.5.8 then all of them, including the four listed below, work perfectly.

AND ... BEFORE ANYONE SAYS IT ... no, I have not added on any new add-ons/extensions.  I have had the same ones for a long long time. The only thing new is FF Versions 3.5.9 and 3.6.3

The ones in Question are:

CookieSafe 3.0.5
MultiSideBar 0.2.3
PasteEmail (Original) 3.2.2
Remove Cookies for Site0.52



Reproducible: Always

Steps to Reproduce:
1.  Start Firefox in Version 3.6.3 or 3.5.9
2.  try to use these four (4) addons .. FF says they are not compatible.
3.  Click on update, do usual reload, and they work perfectly
Actual Results:  
See comments above

Expected Results:  
See comments above

none that I can think of

Updated

8 years ago
Component: Extension Compatibility → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: extension.compatibility → add-ons.manager
Do you have Norton 360 installed on the machines in question?
(Reporter)

Comment 2

8 years ago
Dave,

No ... Not Norton 360 but I do have Norton Internet Security 2010 but that has been on the machine a long time going back before the problem started... by the way, NIS 2010 is on both machines and when I go back to FF 3.5.8 it works fine even though NIS 2010 is on there.
Please restart your computer and before opening Firefox look in the profile directory and see which of the files extensions.ini, extensions.cache, extensions.log and extensions.rdf exist.

http://support.mozilla.com/en-US/kb/Profiles
(Reporter)

Comment 4

8 years ago
Dave,

Sorry about the delay in responding... life is hectic.

Your idea yielded some interesting information ... the before and after  of the profile folder showed that the following three (3) files DID NOT EXIST BEFORE I DID THE UPDATE ... BUT DID EXIST AFTER CLICKING ON THE UPDATE BUTTON IN ADD-ONS!!!!

Extensions.cache
Extensions.rdf
Places.sqlite-journal

By the way, these files do exist in the 3.5.8 version before and after.  They are missing in the "before" on 3.5.9 and 3.6.3

Question ... Does this mean I have a problem or that Firefox has a bug?

Thanks for getting this started for me ... I appreciate it.
(In reply to comment #4)
> Dave,
> 
> Sorry about the delay in responding... life is hectic.
> 
> Your idea yielded some interesting information ... the before and after  of the
> profile folder showed that the following three (3) files DID NOT EXIST BEFORE I
> DID THE UPDATE ... BUT DID EXIST AFTER CLICKING ON THE UPDATE BUTTON IN
> ADD-ONS!!!!

I didn't ask you to do any update so I'll just assume that restarting your computer is causing those files to go away, in which case this is a problem with NIS 2010
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 547708
You need to log in before you can comment on or make changes to this bug.