Closed Bug 557123 Opened 11 years ago Closed 2 years ago

crash [@ nsPop3Sink::IncorporateComplete(nsIMsgWindow*, int)]

Categories

(MailNews Core :: Networking: POP, defect)

x86
All
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: wsmwk, Unassigned)

Details

(Keywords: crash, regression, Whiteboard: [rare])

Crash Data

crash [@ nsPop3Sink::IncorporateComplete(nsIMsgWindow*, int)]

#119 crash for v3.0.3

xref
 bug 492665 2009-07-02 nsMsgLocalMailFolder::DeleteDownloadMsg - nsPop3Sink::IncorporateComplete 
 bug 313234 2009-01-22 nsPop3Sink::IncorporateComplete 

bp-7379c092-2d1c-4ee2-86df-406af2100325
0  	thunderbird.exe  	nsPop3Sink::IncorporateComplete  	 mailnews/local/src/nsPop3Sink.cpp:923
1 	thunderbird.exe 	nsPop3Protocol::HandleLine 	mailnews/local/src/nsPop3Protocol.cpp:3249
2 	thunderbird.exe 	nsPop3Protocol::RetrResponse 	mailnews/local/src/nsPop3Protocol.cpp:3032
3 	thunderbird.exe 	nsPop3Protocol::ProcessProtocolState 	mailnews/local/src/nsPop3Protocol.cpp:3657
4 	thunderbird.exe 	nsMsgProtocol::OnDataAvailable 	mailnews/base/util/nsMsgProtocol.cpp:359
5 	thunderbird.exe 	nsInputStreamPump::OnStateTransfer 	netwerk/base/src/nsInputStreamPump.cpp:508
6 	thunderbird.exe 	nsInputStreamPump::OnInputStreamReady 	netwerk/base/src/nsInputStreamPump.cpp:398
7 	xpcom_core.dll 	nsInputStreamReadyEvent::Run 	xpcom/io/nsStreamUtils.cpp:111
8 	xpcom_core.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:521
9 	xpcom_core.dll 	NS_ProcessNextEvent_P 	objdir-tb/mozilla/xpcom/build/nsThreadUtils.cpp:247
10 	thunderbird.exe 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:170

bp-977aff79-af4c-470e-906a-0e9712100326 (mgroos)
bp-981034cb-3128-4379-a50d-59f3f2100328 (cresed)
bp-dacea3bb-4313-4d82-8d8a-f18002100313 (markus)
Error occurs when downloading new mail. Has appeared sporadically running under Windows 7 since upgrading to TB 3.0.2 and persists through 3.0.4
Enviroment: Win XP SP3 fully patched up, running the latest of Thunderbird.

This has happened since version 3
I have unread folders as default on Thunderbird when it starts up.
First on the list is my inbox, second and third are local search folders and after that a lot of folders. I have a message filter setup that sorts mail into folders below the first 3 folders and sometime some of the mails also causes the search folders to get hits.
If I have selected the inbox (first one) and one or more of the mails causes the search folders to get a new item, thunderbird makes a mess of the msf file.
If I have selected a folder below the search folder the problem does not appear.

Side note. I have seen that sometimes a selected folder gets the same message twice when receiving mail (on the mail list, but if you mark one of them as read then both are now marked as read, the same for delete and so on). But if you select another folder and then go back there is only one message. 

Form looking at the trace above my guess is that it is the handleLine that need a closer look.

Hope that this helps, if not please contact me.
Environment: Windows XP, latest patches, latest Thunderbird
Crashes occurred  with Version 2.X and still remain with Version 3.X

I started Thunderbird offline, on the left the list of "unread folders" is open. 
I go online by selecting one of my POP3 accounts to download all new mails. 
There are several filters defined for this account. The crashes occur when one of the filters is or was applied. The filters move the mails to different local folders.  It looks like there is no specific filter and no specific folder involved. Thunderbird tells in the crash message that there is an index to be repaired. I tried to do this manually because I am not sure if this is done automatically. It didn't help. 
It seems that it helps if the list of "All folders" is open on the left. I can't remember a crash in several weeks now while I took care to have this list opened when I download the mails. There also seems to be no crash when working online and a single mails comes in. 
I'll check what happens when I have the "unread folders" list open again during my first download of 10 to 20 Mails.
(In reply to comment #1)
> ... since upgrading to TB 3.0.2 and persists through 3.0.4

Jeff what is the most recent version where crash did _not_ happen? v3.0.1?


(In reply to comment #2)
> This has happened since version 3

Jesper, so crash did not happen in v2?


(kudos to Jeff, Jesper and Markus for commenting in the bug, as a result of having provided their address in their crash report. Thanks!)
(In reply to comment #4)
> (In reply to comment #1)
> > ... since upgrading to TB 3.0.2 and persists through 3.0.4
> 
> Jeff what is the most recent version where crash did _not_ happen? v3.0.1?

I cannot be entirely sure, unfortunately. I can only be certain it has been happening since 3.0.2

Also, my situation seems to be very similar to Markus, in that I keep the Unread Folders view open, and I have a very extensive list of filters which move incoming emails to various folders under Local Folders.
(In reply to comment #4)

> (kudos to Jeff, Jesper and Markus for commenting in the bug, as a result of
> having provided their address in their crash report. Thanks!)

Can any of you try to figure out what kind of pop server you are talking to (name and version would be handy) ?
I am connecting to two servers. One is pop.gmail.com, and I have no idea what server they are running. The other is at my web hosting (webhost4life). That server is running Courier (http://www.courier-mta.org/). I have a service ticket in to find out what version they are running, and will update this bug if/when I can get that info.
(In reply to comment #4)
> (In reply to comment #1)
> > ... since upgrading to TB 3.0.2 and persists through 3.0.4
> 
> Jeff what is the most recent version where crash did _not_ happen? v3.0.1?
> 
> 
> (In reply to comment #2)
> > This has happened since version 3
> 
> Jesper, so crash did not happen in v2?
This started in version 3. There were no problems in version 2.
> 
> 
> (kudos to Jeff, Jesper and Markus for commenting in the bug, as a result of
> having provided their address in their crash report. Thanks!)
(In reply to comment #6)
> (In reply to comment #4)
> 
> > (kudos to Jeff, Jesper and Markus for commenting in the bug, as a result of
> > having provided their address in their crash report. Thanks!)
> 
> Can any of you try to figure out what kind of pop server you are talking to
> (name and version would be handy) ?
One of my own pop is dovecot 1.2.8 and then I use mail.comcast.net
Keywords: regression
I also almost marked this a regression. but, this is either not a regression or there are two bugs here (or something even more complicated), because 
a) Markus in comment 3 says he saw this in v2,
b) crash sig goes back to at least 3.0a1 bp-2bccc02b-8f8a-49eb-a5d5-317892081224 [1]

It's hard to say without very close examination of the source line numbers between the old crashes and the recent, which I don't have time to do ATM.

[1] some of the oldest v3 crashes - https://crash-stats.mozilla.com/report/list?product=Thunderbird&build_id=&query_search=signature&query_type=exact&query=nsPop3Sink%3A%3AIncorporateComplete%28nsIMsgWindow*%2C%20int%29&date=1%2F01%2F2009&range_value=4&range_unit=weeks&process_type=all&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&signature=nsPop3Sink%3A%3AIncorporateComplete%28nsIMsgWindow*%2C%20int%29&missing_sig=&page=1
Update on POP server: the server running Courier is running version 1.16
Sorry beeing quite for some time. I had the chance to take an easter vacation.

I can get no informnation about the hard or software of my mail provider. Sorry.

I just had the same crash again two times during the download of the same 29 new mails. The third time I opened the "All folders" view on the left first and it worked.
Crash reports have been sent. But these reports are also stored somewhere on my computer, aren't they? Where? Maybe I can check there if thunderbird 2.x had the same problem ...
I have two hardcopies of windows:
1. Error message window of the crash (in german - sorry :-) )
2. Part of the thunderbird window with "All foldes" if there is any doubt what I mean with it.

It looks like I have a good chance to reproduce the crash. What can I do to debug it?
I can not reproduce the problem while using version 3.1.2 of thunderbird.
Does it still exist for annybody else or can you confirm?
In my opinion this problem can be closed.
How can this be done ??
m_outFileStream is most likely null here:

http://hg.mozilla.org/releases/comm-1.9.2/annotate/428ebf09e9ca/mailnews/local/src/nsPop3Sink.cpp#l948

this crash is still happening in 3.1.x
(In reply to comment #15)
> m_outFileStream is most likely null here:
> 
> http://hg.mozilla.org/releases/comm-1.9.2/annotate/428ebf09e9ca/mailnews/local/src/nsPop3Sink.cpp#l948
> 
> this crash is still happening in 3.1.x

bienvenu, will we know why without a protocol log?


Jeff, Jesper, do you still see this crash?
No, I have not had this occur for quite some time now, myself.
Mac crash bp-59930732-371d-4759-a4e8-cd6032110408 v3.1.9
EXC_BAD_ACCESS / KERN_PROTECTION_FAILURE
0x0

Jeff, what AV program do you run?
OS: Windows Vista → All
Most of my machines run ESET NOD32. I have one work box that uses Microsoft ForeFront Endpoint Protection 2010.
This issue has gone away for me.
Crash Signature: [@ nsPop3Sink::IncorporateComplete(nsIMsgWindow*, int)]
bp-f9d71e2d-f803-4be1-9625-45ca22120323 v11
bp-c1af923f-e77a-451f-899f-180bc2120508 v12.0.1

rare - only 1 crash per month per recent release
seems more common though for 3.x releases
Whiteboard: [rare]
Removing myslef on all the bugs I'm cced on. Please NI me if you need something on MailNews Core bugs from me.
Crash Signature: [@ nsPop3Sink::IncorporateComplete(nsIMsgWindow*, int)] → [@ nsPop3Sink::IncorporateComplete(nsIMsgWindow*, int)] [@ nsPop3Sink::IncorporateComplete]
I'm marking this bug as WORKSFORME as bug crashlog signature didn't appear from a long time (over half year].
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
Ups, my bad and due to ( bug #1348631 ) looks like there are sill crashes, so reopening.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Closing because no crash reported since 12 weeks.
Status: REOPENED → RESOLVED
Closed: 4 years ago2 years ago
Resolution: --- → WONTFIX
perhaps fixed by bug 1350687 or bug 1385375
Resolution: WONTFIX → WORKSFORME
You need to log in before you can comment on or make changes to this bug.