Firefox built in updater is frozen

RESOLVED DUPLICATE of bug 539717

Status

()

--
major
RESOLVED DUPLICATE of bug 539717
9 years ago
9 years ago

People

(Reporter: vil2007, Unassigned)

Tracking

1.9.2 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

25.60 KB, application/zip
Details
(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

I can not resume it and it is unresponsive, I have tried restarting but the problem persisted.

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1.Go to Help menu
2.Click resume downloading Firefox 3.6.2

Actual Results:  
Update manager is froze.

Expected Results:  
Update manager should resume.

Using steel brush persona.
(Reporter)

Updated

9 years ago
Version: unspecified → 3.6 Branch

Updated

9 years ago
Component: General → Application Update
Product: Firefox → Toolkit
QA Contact: general → application.update
Version: 3.6 Branch → 1.9.2 Branch
When you say frozen do you mean specifically that the download doesn't resume?
(Reporter)

Comment 2

9 years ago
Yes it does not resume and I am unable to start it.
Please attach (using the 'Add an attachment' link above) the active-update.xml, updates.xml, last-update.log, and backup-update.log which can be located with a default install as follows:

for Windows Vista and above type the following in the Start Menu search box and press return.
%LOCALAPPDATA%
Then navigate to \Mozilla\Firefox\Mozilla Firefox\

for Windows prior to Windows Vista type the following in the Start Menu -> run box and press return.
%USERPROFILE%
Then navigate to \Local Settings\Application Data\Mozilla\Firefox\Mozilla Firefox\

The last-update.log and backup-update.log are located in the updates directory.

Also, if there is a 0 directory in the updates directory please add a comment as to which files are located in it. If there is an update.status file in it please attach it as well.

Thanks
(Reporter)

Comment 4

9 years ago
Created attachment 436951 [details]
Update info files

update.status and update.version are in /0
Thanks! We've had a couple of other bugs with the same symptoms but this is the first where I've received the files requested in full which is a big help in understanding the problem and coming up with a fix for this.
I won't need any additional details so you can resolve this problem on your system by deleting the active-update.xml and the files in the 0 directory.
(Reporter)

Comment 7

9 years ago
Thanks for your help and I'm glad I was able to further the progress with the fix for this bug.
This is a duplicate of bug 539717. I've been investigating how to best fix this and will hopefully have something in a week or so. Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 539717
You need to log in before you can comment on or make changes to this bug.