more than one thousand duplicates of original received message

RESOLVED INCOMPLETE

Status

Thunderbird
General
RESOLVED INCOMPLETE
8 years ago
8 years ago

People

(Reporter: Gary Whittaker, Unassigned)

Tracking

x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.1.249.1045 Safari/532.5
Build Identifier: 3.0.4

I am getting duplicates of an email exactly every ten minutes. This is because of "Check for new messages every 10 minutes", which apparently is the default. I changed it to 1 minute and i got duplicates every minute. I am now using Windows Live Mail and i am not having the problem. I only get duplicates on this one email message. Why this one i have no clue. If i delete them all, and even do a global search to make sure they're all gone, it doesn't matter. They continue to appear. This has been going on now for 24 days now. 

Reproducible: Always

Steps to Reproduce:
1. Do nothing. I automatically get these duplicates. I can't stop them.
2.
3.
Actual Results:  
As above, i keep getting exactly duplicates of the original message. I've done file compares between the duplicates and the only thing different is in the first line of the email header, namely when i received it.

Expected Results:  
Expected result is to not get these duplicates.

It should not have given me more than 1500 duplicates (and still counting).
(In reply to comment #0)

What is Thunderbird version you are using? (Help/About Thunderbird)
Here is B.M.O, not support forum. So, if bug report at B.M.O(report of Tb's flaw in code), "problem with which version of Tb" is one of most important thing.

First use of Thunderbird? Or you upgraded Thunderbird, and your problem started to occur after the upgrade?

Does you problem occur on what type of mail account? POP3? IMAP?
If POP3, "Leave Messages on Server" is checked? Or unchecked?
If IMAP, "offline use=on"? Or "offline use=off"? (folder properties/Synchronization)

If POP3, phenomenon of "duplicate download" itself is not surprizing, if "Leave Messages on Server" is off and if timeout occurs during dowload of mails.
POP3 download roughly consists of;
  1. Connect to POP3 server, login
  2. LIST  (get message-no and size)
  3. UILD  (get mapping of message-no to UIDL)
  4. RETR for all message-no (download of mail data)
  5. DLET for all message-no (delete request)
  6. QUIT (loggoff)
And, spec of protocol of POP3 is;
  Final processing of DLET at POP3 server should be executed
  after successfull QUIT at above step 6.
So, if timeout, connection error, ..., occurs after start of step 4 before step 6, all mails are downloaded again at next connection.

Does you POP3 server return data or response within a reasonable time? As no problem with "Windows Live Mail", your timeout value setting of Tb(probably you never changed from default value by Tb) may be too small for your server.
MS's default value of timeout seems far larger than Tb, and MS's mailer seems to have capability to ask user about action upon timeout...
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> (In reply to comment #0)
> 
> What is Thunderbird version you are using? (Help/About Thunderbird)
> Here is B.M.O, not support forum. So, if bug report at B.M.O(report of Tb's
> flaw in code), "problem with which version of Tb" is one of most important
> thing.
> 
> First use of Thunderbird? Or you upgraded Thunderbird, and your problem started
> to occur after the upgrade?
> 
> Does you problem occur on what type of mail account? POP3? IMAP?
> If POP3, "Leave Messages on Server" is checked? Or unchecked?
> If IMAP, "offline use=on"? Or "offline use=off"? (folder
> properties/Synchronization)
> 
> If POP3, phenomenon of "duplicate download" itself is not surprizing, if "Leave
> Messages on Server" is off and if timeout occurs during dowload of mails.
> POP3 download roughly consists of;
>   1. Connect to POP3 server, login
>   2. LIST  (get message-no and size)
>   3. UILD  (get mapping of message-no to UIDL)
>   4. RETR for all message-no (download of mail data)
>   5. DLET for all message-no (delete request)
>   6. QUIT (loggoff)
> And, spec of protocol of POP3 is;
>   Final processing of DLET at POP3 server should be executed
>   after successfull QUIT at above step 6.
> So, if timeout, connection error, ..., occurs after start of step 4 before step
> 6, all mails are downloaded again at next connection.
> 
> Does you POP3 server return data or response within a reasonable time? As no
> problem with "Windows Live Mail", your timeout value setting of Tb(probably you
> never changed from default value by Tb) may be too small for your server.
> MS's default value of timeout seems far larger than Tb, and MS's mailer seems
> to have capability to ask user about action upon timeout...

I am using version 3.0.4. I don't know what B.M.O. stands for. 

No, this is not my first use of Thunderbird. I have been using this version (3.0.4) for more than two months. I am a long-time Thunderbird user. My problem started after i received that email. It is the *only* email that i have received duplicates of. Everything else on Thunderbird works fine.

I use POP3. Leave messages on server is checked.

As far as "Does your POP3 server return data or respond within a reasonable time?", i don't think there's a problem there. It seems to respond reasonably quickly. As of this morning, 7am, 4/5/2010, i have two more duplicates on Thunderbird, but none are showing up on Windows Live Mail. After having been asking if i want to make Window Live Mail my primary mail client i answered yes. I agree that the default value for checking the mail server is much greater than Thunderbird. I believe the default is 30 minutes. After talking with the person who sent the original message, they claim the problem is on my end. He even talked with the person who hosts his site and he also thinks the problem is on my end. Talking with my ISP, Time Warner Cable, was not helpful. She asked me to temporarily uncheck the checking of my email by AVG Free. That didn't help. She gave me a ticket # to call back but i haven't done that yet.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.0
(In reply to comment #2)
> I don't know what B.M.O. stands for. 

If so, why did you open "bug at B.M.O"? Who suggested you to open "bug at B.M.O" for your problem you experienced while using Thuderbird? What is your purpose of opening "bug at B.M.O(report of Tb's flaw in code)" without data such as log, trace, steps to reproduce, ...? Do you think B.M.O is one of support forum? If so, by what document did you think so?
(Reporter)

Comment 4

8 years ago
Please excuse my lack of following proper protocol for "reporting bug." I didn't know where else to turn. In any case, for whatever reason, i am no longer getting duplicate copies of this one email. Thank you WADA. I don't know how to close, or delete this bug report.
(In reply to comment #2)
> I am a long-time Thunderbird user. My problem started after i received that email. 
> It is the *only* email that i have received duplicates of.

> As of this morning, 7am, 4/5/2010, i have two more duplicates on
> Thunderbird, but none are showing up on Windows Live Mail.

(In reply to comment #4)
> i am no longer getting duplicate copies of this one email.

Did you delete the problematic mail via Web Mail inrterface or by other mailer?
If so, probably dup of other bug report.
(1) Bad mail exists at POP3 server. (Mail sender's bug)
(2) Upon retrieve by client, POP3 server doesn't properly return mail data
    and/or response for the bad mail. (POP3 server's bug)
    - client waits for response forever then timeout
    - connection is killed by server
(3) Tb stops download process at error of step (2).
    Windows Live Mail probably skips the timed out mail.
AFAIR, enhancement such as "skip of bad mail", "partial data disply such as UIDL, and capability to delete it", is requested in other bug, in case of error by POP3 server side bug.
BMO stands for Bugzilla.mozilla.org.(In reply to comment #4)

> Please excuse my lack of following proper protocol for "reporting bug." I
> didn't know where else to turn. In any case, for whatever reason, i am no
> longer getting duplicate copies of this one email. Thank you WADA. I don't know
> how to close, or delete this bug report.

And you didn't do anything to change this ?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Updated

8 years ago
Resolution: INCOMPLETE → WORKSFORME
WORKSFORME at bugzilla.mozilla.org(B.M.O) means "Tb's bug really existed, and problem don't occur with newer builds, so bug of Tb was probably fixed by unknown patch already".
Changing back to INCOMPLETE, because this bug is never INVALID if my guess of comment #5 is right.
Resolution: WORKSFORME → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.