[preview.amo] zamboni update script isn't getting a new package version

RESOLVED FIXED

Status

Infrastructure & Operations
WebOps: Other
--
critical
RESOLVED FIXED
8 years ago
4 years ago

People

(Reporter: jbalogh, Assigned: oremj)

Tracking

Details

(Reporter)

Description

8 years ago
http://sm-hudson01.mozilla.org/pypi/pip-manifest.txt shows django-cache-machine==0.4, which changed from 0.3 recently.  http://sm-hudson01.mozilla.org/pypi/django-cache-machine/ has 0.3 and 0.4.

According to https://preview.addons.mozilla.org/z/en-US/firefox/nickspages/featured+categories and the error emails I'm getting, preview is only running version 0.3.

`import caching; print caching.__version__` will show what we have installed.
(Reporter)

Updated

8 years ago
Duplicate of this bug: 557164
Severity: minor → normal
(Assignee)

Updated

8 years ago
Assignee: server-ops → jeremy.orem+bugs
(Assignee)

Comment 2

8 years ago
[root@pm-app-amo24 ~]# /data/virtualenvs_preview/zamboni/bin/pip -q install -U -i http://sm-hudson01.mozilla.org/pypi/ -r http://sm-hudson01.mozilla.org/pypi/pip-manifest.txt
  Source in /data/virtualenvs_preview/zamboni/build/GitPython has the version 0.1.6, which does not match the requirement GitPython==0.1.7 (from -r http://sm-hudson01.mozilla.org/pypi/pip-manifest.txt (line 8))
Source in /data/virtualenvs_preview/zamboni/build/GitPython has version 0.1.6 that conflicts with GitPython==0.1.7 (from -r http://sm-hudson01.mozilla.org/pypi/pip-manifest.txt (line 8))
Storing complete log in ./pip-log.txt
This is blocking QA.
Severity: normal → critical
I'm not quite sure how things are laid out, but some general suggestions.

ls on /data/virtualenv_preview/zamboni/lib/python2.6/site-packages might help, as would the content of /data/virtualenv_preview/zamboni/lib/python2.6/site-packages/*.egg-info/PKG-INFO

I'm not really sure what's going on... running this would show something too (per jbalogh's suggestion):

/data/virtualenv_preview/zamboni/bin/python -c 'import caching; print caching.__version__'

And lastly there is a chance that the environment is upgraded, but mod_wsgi or whatever is running the code is stale and needs to be kicked.
Darn, nothing there was particularly revelatory.

If you do:

 /data/virtualenvs_preview/zamboni/bin/pip install django-cache-machine==0.4

it should update the version (you could confirm by rerunning the '...import caching' command).  I'm not sure if doing it once and fixing it in place will be enough to resolve the problem for future updates.

Ah... it occurs to me that it might get as far as installing GitPython and fail because of that error, and not process the rest of the file, so basically pip-manifest.txt is being ignored.  So basically installing pip-manifest isn't working.  I checked http://sm-hudson01.mozilla.org/pypi/GitPython/ and it's correct, including the zip file and setup.py (i.e., it is 0.1.7).  I'm not sure where /data/virtualenvs_preview/zamboni/build/GitPython is coming from; either why it is there, or why pip is picking it up.
Severity: critical → normal
Severity: normal → critical
(Assignee)

Comment 7

8 years ago
I did rm -rf /data/virtualenvs_preview/zamboni/build/GitPython and everything seems to be working again.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
I suspect something in the build process (maybe involving a bundle that failed to install) left build/GitPython around and pip picked it up and instead of treating "GitPython" like the name of a package, it treated it like a directory to install, or treated build/ as a place to find packages.  Or... something like that, the specifics are unclear to me.

If build/ regularly gets stuff in it, it might be good to wipe it as part of the build process to ensure it doesn't cause problems like this.
Component: Server Operations: Web Operations → WebOps: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.