iFrames are not being handled correctly

UNCONFIRMED
Unassigned

Status

()

Firefox
General
--
major
UNCONFIRMED
8 years ago
7 years ago

People

(Reporter: Itty, Unassigned)

Tracking

3.6 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; MS-RTC LM 8)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

I built my site to use iFrames to not only show 2 frames (it only shows 1) but to allow each frame to show up as it's own item.  The listed frames have no background colour and so should not have any background colour set but instead they inherit the background colour of the iFrame page that shows them.  This is wrong according to HTML 4.01.

Reproducible: Always

Steps to Reproduce:
1. Open the linked site in both IE (any) and Firefox.  You will see the difference.
2) IE shows it correctly.
(Reporter)

Updated

8 years ago
Priority: -- → P2
Version: unspecified → 3.6 Branch

Updated

8 years ago
Priority: P2 → --

Comment 1

8 years ago
(In reply to comment #0)
> The listed frames have no
> background colour and so should not have any background colour set but instead
> they inherit the background colour of the iFrame page that shows them.  

Duplicate of bug 346398 -> Core bug 154957?

Comment 2

7 years ago
Can you still reproduce this bug in Firefox 6?

Please update to Firefox 6 or later, update your plugins, and retest in a new profile. If you still see the issue with the updated version of Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME.

http://getfirefox.com/

Updated

7 years ago
Summary: iFrames are not being handled correctly in many ways → iFrames are not being handled correctly
You need to log in before you can comment on or make changes to this bug.