On clicking a URL (a href) in a frameset (frames), the URL is ignored and the frame disappears

RESOLVED INVALID

Status

()

RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: spurrymoses, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Caused by AdBlock Plus 1.2], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)

This bug description does depend on visiting the URL provided to explain the problem clearly. What actually happens is a little bizarre.
I have a frameset with 3 frames (left, right (top-bottom)). 
I have a link in the right-top frame to take the user to "Kanji Flash Cards", it's very prominent anchor (link), with 2 large images displaying kanji flash cards. Simply clicking on this link, doesn't take the user to the URL, but rather suddenly destroys the entire top frame (it disappears) the bottom frame is then expanded to fill the top and bottom areas and then that's it. The URL destination is ignored.
Perhaps it's technically a "browser-crash", given the way it aborts and then self-destructs, although there's no exception or message box.

Reproducible: Always

Steps to Reproduce:
1. Go to the the URL provided 
2. Click one of the large images on the right under the heading "Kanji Flash Cards for JLPT 3/4" (both images are anchored to a URL)
3. Watch the browser fail to follow the URL and the top frame suddenly disappear
Actual Results:  
The top frame disappeared and the URL was not navigated to

Expected Results:  
The top frame should remain where it is (unaltered) and the link should be navigated to (specifically in the top frame since the target is "_top")
It works on IE8, Chrome, Opera10

I tried a few variations to isolate the issue with no luck.
There are 2 images within the anchor tag, I tried removing one. 
I tried removing the "_top" target on the href.
I tried a different (simpler URL).
I tried wrapping each image in an anchor tag.
I suspect it maybe some complication with the fact that a table is used for the layout, rather than the actual anchor or image tags... but this is a guess.

Comment 1

9 years ago
I get the same result in IE, FF, Chrome and Safari - all load the link in the full tab. Doesn't look like a FF bug but a website issue
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> I get the same result in IE, FF, Chrome and Safari - all load the link in the
> full tab. Doesn't look like a FF bug but a website issue

Hi, 

I just checked again, you must have misunderstood the issue:
I just retried using IE8, and it most definitely does *not do it*
I just tried Chrome, and it most definitely *does not do it*

I can't get any other version of any browser to behave in the same incorrect way as Firefox does

I must have not explained something properly?

Can I just clarify:
Go to the website - http://www.jlptstudy.com/4/jlpt4_kanji-list_main.html
Click on the large image link just below the words "Kanji Flash Cards for JLPT 3/4"
All browsers will simply take you to the URL - http://www.jbox.com/SEARCH/%22kanji_practice_flashcards%22/1/

Firefox *does not go to the URL*
It goes berzerk, loses the top frame and presents something that doesn't make any sense.

Comment 3

9 years ago
FF is going to the URL as described on my machines (tried 2 - Win 7 and -> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729; .NET4.0E) ID:20100401080539)

Please try on your machine in safe mode (http://support.mozilla.com/en-US/kb/Safe+Mode) or with a new profile (http://support.mozilla.com/en-US/kb/Managing+profiles)
(Reporter)

Comment 4

9 years ago
(In reply to comment #3)
> FF is going to the URL as described on my machines (tried 2 - Win 7 and ->
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401
> Firefox/3.6.3 ( .NET CLR 3.5.30729; .NET4.0E) ID:20100401080539)
> 
> Please try on your machine in safe mode
> (http://support.mozilla.com/en-US/kb/Safe+Mode) or with a new profile
> (http://support.mozilla.com/en-US/kb/Managing+profiles)

Oh OK. Must be something more specific.
Maybe it's specific to a plugin, sorry I didn't try uninstalling all of them first. Will try and come back.
(Reporter)

Comment 5

9 years ago
Damn, I'm so sorry, it didn't occur to me that it could be a plugin.
The AdBlock Plus plugin 1.2, is causing the issue.
When I disable it, it works as expected.

(In reply to comment #2)
> (In reply to comment #1)
> > I get the same result in IE, FF, Chrome and Safari - all load the link in the
> > full tab. Doesn't look like a FF bug but a website issue
> 
> Hi, 
> 
> I just checked again, you must have misunderstood the issue:
> I just retried using IE8, and it most definitely does *not do it*
> I just tried Chrome, and it most definitely *does not do it*
> 
> I can't get any other version of any browser to behave in the same incorrect
> way as Firefox does
> 
> I must have not explained something properly?
> 
> Can I just clarify:
> Go to the website - http://www.jlptstudy.com/4/jlpt4_kanji-list_main.html
> Click on the large image link just below the words "Kanji Flash Cards for JLPT
> 3/4"
> All browsers will simply take you to the URL -
> http://www.jbox.com/SEARCH/%22kanji_practice_flashcards%22/1/
> 
> Firefox *does not go to the URL*
> It goes berzerk, loses the top frame and presents something that doesn't make
> any sense.

(In reply to comment #2)
> (In reply to comment #1)
> > I get the same result in IE, FF, Chrome and Safari - all load the link in the
> > full tab. Doesn't look like a FF bug but a website issue
> 
> Hi, 
> 
> I just checked again, you must have misunderstood the issue:
> I just retried using IE8, and it most definitely does *not do it*
> I just tried Chrome, and it most definitely *does not do it*
> 
> I can't get any other version of any browser to behave in the same incorrect
> way as Firefox does
> 
> I must have not explained something properly?
> 
> Can I just clarify:
> Go to the website - http://www.jlptstudy.com/4/jlpt4_kanji-list_main.html
> Click on the large image link just below the words "Kanji Flash Cards for JLPT
> 3/4"
> All browsers will simply take you to the URL -
> http://www.jbox.com/SEARCH/%22kanji_practice_flashcards%22/1/
> 
> Firefox *does not go to the URL*
> It goes berzerk, loses the top frame and presents something that doesn't make
> any sense.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Updated

9 years ago
Component: General → Extension Compatibility
QA Contact: general → extension.compatibility
Whiteboard: [Caused by AdBlock Plus 1.2]
You need to log in before you can comment on or make changes to this bug.