Cookies disabled after deleting them

RESOLVED INVALID

Status

()

Firefox
General
--
minor
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: stecklars, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.1.8) Gecko/20100214 Ubuntu/9.10 (karmic) Firefox/3.5.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.1.8) Gecko/20100214 Ubuntu/9.10 (karmic) Firefox/3.5.8

If you go for example to gmail.com, stay there, delete your cookies
and then try to login you'll get the message that your cookies are disabled.
This error is 100% reproducible on Linux, as well as on x86_64 Windows 7 for me.
Then, if you click the back button and login again, everything is working fine.

Reproducible: Always

Steps to Reproduce:
1.Go to gmail.com (for example)
2.Delete Cookies
3.Try to login
Actual Results:  
You'll get a message that cookies are disabled.

Expected Results:  
Cookies should stay enabled after deleting them.
(Reporter)

Comment 1

8 years ago
It looks like this only happens on Gmail.
And why should that be a browser issue if gmail detects that cookies aren't working (their routine seems to be confused by the deleted cookies) ?
(Reporter)

Comment 3

8 years ago
I just tried it on Google Chrome and the same happens there.
It really looks like it's a gmail issue.
marking invalid

This seems to be caused by a gmail script that get's confused by the deleted cookie while you are at the site.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.