WebGL colour/shading broken on OS X 10.6

RESOLVED WORKSFORME

Status

()

Core
Canvas: WebGL
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Joe Drew (not getting mail), Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
Look at the URL. On the right is the desired rendering, on the left is how it is on your system. If you look at this page in OS X 10.5, they match. If you look at it in 10.6, it looks like http://www.flickr.com/photos/11280278@N04/4494213664/

Comment 1

8 years ago
The above example does not work on Vista x64 as well. It doesn't even render a white sphere, only a black canvas
(Reporter)

Comment 2

8 years ago
That should probably be a separate bug, Anna - please file it! :)

Comment 3

8 years ago
The above example does not work on Vista x64 as well. It doesn't even render a white sphere, only a black canvas
Here's another one that's failing - http://pointmarker.com/webgl/test2.html  Works on Windows, just white for me on 10.6.
Summary: processing Spotlight() demo works in WebGL on 10.5, fails on 10.6 → WebGL colour/shading broken on OS X 10.6

Comment 5

7 years ago
I am seeing this light problem on other browsers.  Chromium, Safari and Minefield are all show this.  Is this a 10.6 issue?  Is this a problem with how we are implementing lighting?

Live page here:
http://www.c3dl.org/index.php/webgl-demos/cross-browser-orbiter
I can't reproduce using http://matrix.senecac.on.ca/~asobiepa/Processing/0.8/examples/seneca/material/tests/spotlight%202/spotlight.html or with demo in comment #5 with b7-ish on Win32 64-bit.  Can someone confirm that whatever the issue was is fixed?
Yeah, that page is working for me now too, where before it was just white.  Andor/Cathy/Anna, can you look at your previous failing examples and confirm?
K, based on bug 557837, gonna close this -- reopen if it's still broken, pls!
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.